1
$\begingroup$

enter image description here2]2I'm making an animation by editing a previous created one. I'm using version 2.73 on an old Dell laptop with Vista OS and the render engine is Blender Render.

There is a single light source (sun) above the 4 objects in the scene. 3 were newly created, one is from the older animation. All objects are being rendered (Blender Render) as textures. The lighting appears correct (light on top, shaded below) except the old object which appears reversed (dark on top, light on bottom). The camera view has been changed in the new animation.

PNG Frame

It's the torpedo that appears lit from below instead of above.

If I open the blender file I started editing into the new one, then import an underwater mine I created in the second version, without changing the camera view or lighting, the problem is reversed. There the torpedo is lit correctly but the mine is backwards

pic 2.

I think I've narrowed the issue down to being related to using textures in the rendering. The problem doesn't exist with view port shading set to materials. As you can see from this picture:

pic 3

Unfortunately I need to render as textures for later objects appearing in the animation. Hope this helps point to the possible problem.

Is there a legacy aspect of the old object (shading correct previously) overriding the new camera positioning, or as a relatively new user, am I overlooking something simple I don't know about? Open to any suggestions that point me in the right direction, but I currently can't include the file for inspection, sorry. Much appreciation.

[![Fixed Object] Followup: I continue to have major system errors (runtime, display driver, etc. frequent crashes) computer/application wide. Wanted to send a view (see pic 4) of the newly created mine object among the older version to illustrate that whatever the problem was, it was surely operator error on my part. The new object renders correctly.

$\endgroup$
  • 7
    $\begingroup$ Don't you think some pictures could help to understand what you are saying here? $\endgroup$ – lemon Aug 4 '16 at 19:00
  • 1
    $\begingroup$ @SwanSong2 it would be easier to help you if you upload your file. $\endgroup$ – cegaton Aug 6 '16 at 17:41
  • 2
    $\begingroup$ Have you checked the object's normals? This is a very weird problem... Try pressing Ctrl-N $\endgroup$ – someonewithpc Aug 6 '16 at 18:03
  • 1
    $\begingroup$ Use blend-exchange.giantcowfilms.com to upload, then add the resluting link as part of the text for your question. $\endgroup$ – cegaton Aug 6 '16 at 23:14
  • 1
    $\begingroup$ if that can help, there is a "compress" option if you "save as" your file. $\endgroup$ – lemon Aug 7 '16 at 8:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.