3
$\begingroup$

I have done BlenderGuru's Quick Rigid Body Fun on Rigid Body Collisions.

enter image description here

Regarding this .blend file:

When you play the animation, the cubes start falling down long before they are hit by the wrecking ball. This is because of gravity and because there is some space between the cubes. How can you prevent the cubes falling down or at least arrange that the cubes don't fall down before they are hit by the wrecking ball?

P.S Blender Guru says it is necessary to have some space between the cubes because if there is no space the wall will explode. I have here another .blend file...

...where there is no space between the cubes, so I don't think he is right. But the stones don't behave like there is a wall .... hmmmm ???

$\endgroup$
  • $\begingroup$ See blender.stackexchange.com/questions/2620/… $\endgroup$ – Mr Zak Aug 4 '16 at 18:27
  • $\begingroup$ You need to reset the origin points of the cubes after you separate them from the arrays they were part of. They fall because the origin point is at the same place for all of them once you separate them. he explains to use Ctrl-Alt-Shift-C > Geometry to Origin, but when I do it, the cubes all end up at the same location, so I don't know what's up with that. $\endgroup$ – Anthony Forwood Aug 4 '16 at 21:26
  • $\begingroup$ The reason I couldn't change the origin points was because I had rigid body physics turned on. I had to turn it off for the cubes first. $\endgroup$ – Anthony Forwood Aug 4 '16 at 21:32
  • $\begingroup$ Now my physics isn't working at all. $\endgroup$ – Anthony Forwood Aug 4 '16 at 21:52
6
$\begingroup$

The simplest answer to this is to apply transforms to all of the cubes. Ctrl+A>Scale and then in the physics panel, enable deactivation and start deactivated for all cubes so that the simulation does not take over the objects until they interact. Just enable the option for one, then choose copy from active in the Tool shelf with all cubes selected.

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ It seems to work and a indeed a simple solution. Thanks $\endgroup$ – Old Man Aug 5 '16 at 8:08
1
$\begingroup$

I started with the first linked .blend file. After my short, 14-step method, I achieved this:

enter image description here

  1. Make sure all the cubes and the cubes only are selected. The active object must be a cube.
  2. Go to frame 85.
  3. Go to the Properties panel > Physics tab > Rigid Body dropdown and uncheck the Dynamic checkbox.
  4. Hover over the Dynamic checkbox and key I to insert a keyframe. It should turn from grey to yellow.
  5. Key RightArrow to move to frame 86.
  6. Go to the Properties panel > Physics tab > Rigid Body dropdown and check the Dynamic checkbox.
  7. Hover over the Dynamic checkbox and key I to insert a keyframe. It should turn from green to yellow.
  8. Key Shift + LeftArrow to go back to frame 1. Any simulated physics should have gone away.
  9. Key Ctrl + J to join all of the cubes.
  10. Tab into Edit Mode.
  11. Key P to open the Separate menu and either key 3 or manually select By Loose Parts. All of the cubes should now have the aforeinserted (heh) keyframes.
  12. Tab out of Edit Mode.
  13. Select all cubes, if they are not already selected.
  14. Key Shift + Ctrl + Alt + C to open the Origin menu and select Origin to Geometry.

Here is the finished .blend file that produced the .gif at the beginning:

$\endgroup$
  • 2
    $\begingroup$ This is more like a workaround than a real solution. As animation data is handled with, the only thing left is to link it. Already given solution - blender.stackexchange.com/questions/2620/… $\endgroup$ – Mr Zak Aug 4 '16 at 18:27
  • $\begingroup$ @ShadyPuck do not really understand your comments, or did I miss something ? $\endgroup$ – Old Man Aug 4 '16 at 23:02
  • $\begingroup$ @OldMan Lemon was here earlier, and we were discussing the fact that I forgot to write up steps 12-14. Lemon is someone who prefers to delete their comments after posting. If my answer helped, please consider marking it as accepted. $\endgroup$ – Shady Puck Aug 4 '16 at 23:41
  • 1
    $\begingroup$ @ShadyPuck so your solution is essentially to work with keyframes and exclude the cubes from the animation till they get hit by using keyframes and the Dynamic check box ? The part that I don't understand is al joining, separating of the cubes (step 10 -14). I mean I already did separate the cubes and did set the origins, did not I ? $\endgroup$ – Old Man Aug 5 '16 at 8:01
  • $\begingroup$ @OldMan The joining and separating copies the keyframes from one object to every object. $\endgroup$ – Shady Puck Aug 5 '16 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.