4
$\begingroup$

When animating, I just realized that sometimes when I add a keyframe, it appears in the dopesheet but not in the timeline. Why?

$\endgroup$
4
  • $\begingroup$ Could you post a .blend where this happens? $\endgroup$
    – Mörkö
    Aug 4 '16 at 8:54
  • $\begingroup$ and / or elaborate on which property you are keyframing when this happens with a screenshot, or a datapath (right click select Copy Datapath) $\endgroup$
    – batFINGER
    Aug 4 '16 at 9:01
  • 2
    $\begingroup$ Timeline requires you to have the object selected, where as the dope sheet allows you to see any and all keyframes. $\endgroup$
    – Luka ash
    Aug 4 '16 at 14:27
  • $\begingroup$ Thank you all for the answers above...everything is okay now..i just hadnt selected any object in the view port $\endgroup$ Aug 4 '16 at 20:05
2
$\begingroup$

The timeline and dopesheet are very different things. The timeline isn't very interactive. The only thing you can do with it is change what frame your on and add markers. The dopesheet allows to move keyframes, copy keyframes, and way more. The timeline will only show keyframes for the object that's currently selected. but you can't do anything with a keyframe on the timeline.

$\endgroup$
14
$\begingroup$

If anyone is having problems seeing keyframes on the timeline even though the object is selected, on the far left of the timeline there is a tiny arrow, if you click and drag this open you will see a summary of keyed items. Opening all of these and selecting one or two will, kinda reset your view.

$\endgroup$
3
  • $\begingroup$ Yep, and without selecting an object at all, just clicking the arrow. Seems like a bug. $\endgroup$
    – person27
    Aug 3 '20 at 2:00
  • $\begingroup$ The occasional bug is still there (2.91) and this solution still kinda works. In my case even a tiny arrow revealed nothing, but new empty column. I mouse-dragged to resize the new column width and the "Summary" suddenly appeared and with it the keyframes. $\endgroup$ Dec 29 '20 at 13:47
  • $\begingroup$ I just bumped into this problem on Blender 2.93.2 and this procedure worked. Thanks. $\endgroup$
    – bigLarry
    Aug 12 '21 at 14:54
1
$\begingroup$

Both are different and have different usage. From it's name, the Timeline allows you to change the time of the animation played. Along with the current frame, only inserted keyframes (using I) will be displayed on the timeline. More details can be found in Blender's manual Timeline Editor

While Blender's Dopesheet gives you a "bird's eye-view" of everything occurring within the seen. More details can be found in Dopesheet

$\endgroup$
1
$\begingroup$

The timeline is like the dopesheet now, you can move up-down keyframes with the scroll mouse, some times as we work a lot with the zoom in the viewport, the keyframes are going up with ).

Just click (⇧ Shift + Scroll Down) in the Timeline and you should see your keyframes.

$\endgroup$
0
$\begingroup$

For anyone who has a similar issue I recommend that you use the Middle Mouse button to look around in your timeline. I had the same issue as the one above but upon closer inspection I realized that I had not looked further up my timeline and that was the issue.

$\endgroup$
0
$\begingroup$

If you're in Blender 2.82+ click the eye icon twice to see graphs/keyframes that aren't showing up.

Similar answer from Unnamed Sentient Being got me fiddling with things..

Click eye icon to reveal graphs click eye icon to reveal graphs

$\endgroup$
0
$\begingroup$

enter image description here

If you aren't able see those diamond key-frames in your timeline for selected object then try this out.

  1. In Timeline, in left-bottom corner, you can see a button named View, click on it.
  2. After clicking, you will see an option called Frame All, select it.
  3. After that click on whichever object you want to see key-frame of
$\endgroup$
0
$\begingroup$

When other answers didn't help I found that I had copied animation data to the rig. Could not see the keyframes in Dope Sheet or Timeline. When I copied the data I was in Pose Mode. Fiddling with Pose Mode I could not see the keyframes using any of the solutions above.

Switching to Object Mode and then selecting the rig again made the keyframes appear. Switching back to Pose Mode, they were still there. An interesting nuance, but this solution worked, and may work in other scenarios as well.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.