5
$\begingroup$

In the following we are testing cell fracturing applied to a UV-sphere (remeshed to blocks, BTW). We then apply rigidbody physics to the generated parts.

When we start simulation as you can see below it looks like an explosion! Why? Secondly parts are continuing to bounce for long time even though their bouncing property is zero. To avoid parts going out of camera we put a passive rigidbody (big sphere). It's bouncing property is also zero. Why they act like that and how to solve this? For all parts and big sphere the collision-shape is mesh and friction value is 0.5.

frame 1

frame 5

frame 250

animation

Update:
Convex-hull collision, all shards are convex
Convex-hull collision, all shards are convex


Convex-hull collision, NOT all shards are convex
Convex-hull collision, not all shards are convex


Mesh collision, all shards are convex
Mesh collision, all shards are convex


Mesh collision, NOT all shards are convex
Mesh collision, not all shards are convex

For the above simulations:
Split Impulse is checked, Steps Per Second=120, Solver Iterations=50.

As can be seen from the above simulation results:

  • if all shards are convex, convex-hull collision results in the best.
  • if not all shards are convex, mesh collision results in the best.

Not sure why it is like this, after all!


Update:
We incorporated all the suggestions below you can find in the answer and comments, but it seems there are lots of difficulties that are not solved yet, after all! Look at the following simulations where an spherical shelf is fractured. None of convex-hull or mesh collision-shape works correctly. Check the animation in the right, it looks it is not a shard but a airplane!! This is because of use of convex-hull for shards. Check the middle one (mesh collision-shape for shards) they don't act like shard but like spring! :(

chull mesh shard

$\endgroup$
  • $\begingroup$ Try enabling Split Impulse in Scene > Rigid body world. Also try using Convex Hull instead of mesh for the shards. $\endgroup$ – gandalf3 Jan 1 '14 at 9:02
  • $\begingroup$ Related: Tips for making Mesh Rigid-body collision shapes more stable $\endgroup$ – gandalf3 Jan 2 '14 at 21:53
  • $\begingroup$ We applied all the given suggestions below but still no success to simulate a simple but working fracturing! :( $\endgroup$ – Developer Jan 5 '14 at 6:17
7
$\begingroup$

Basically it happens because when it simulates, the solver thinks meshes are intersecting with each other and it tries to separate them asap, giving the shards (sometimes) big speeds. Already mentioned Split Impulse might work and should in most cases, but there are couple more things you could try:

  • In Scene -> Rigid Body World increase Steps Per Second and Solver Iterations for more accurate simulation.

  • Try changing between Convex Hull and Mesh in Physics -> Rigid Body (for each simulated object) and adjust the Collision Margin parameter; it is not said which works better for any scene, Convex Hull simplifies the simulation so it may speed up the process, but mess the simulation even more,

  • Increase Margin when performing cell fracturing - this adds some space between the shards and may help a bit with simulation,

  • Scale whole scene up and apply scale for all objects - usually simulation performs much better for bigger objects; if you use this method, you might want to increase simulation speed in Scene -> Rigid Body World.

To copy parameters for all rigid bodies use Rigid Body Tools, select all objects you want to set parameters (like Margin for example) and copy from active Rigid body object (the one you have selected last).

$\endgroup$
  • 1
    $\begingroup$ We accepted this due to nice points, although if you consider the update there are still strange thing happening. Note also, in the update, objects are already scaled to be big. $\endgroup$ – Developer Jan 2 '14 at 6:21
  • $\begingroup$ @Developer Make sure all the origins are centered, try A Select all, Ctrl+Alt+Shift+C > Snap origin to center of mass. $\endgroup$ – gandalf3 Jan 2 '14 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.