2
$\begingroup$

I am using Windows 10 32-Bits, and whenever I start blender I get this error message: Blender Error Message

System info

Display info

I have tried re-starting it and also searching for the solution over the internet, but in vain, I have not found any solution.

Please help...

$\endgroup$
  • $\begingroup$ Since 2.77 Blender requires OpenGL 2.1... If your card does not support it, I think you'll have to get an older version of Blender $\endgroup$ – lemon Aug 3 '16 at 15:09
  • $\begingroup$ You should state what graphics card and driver you are using. The error message says what would cause it. $\endgroup$ – Bradman175 Aug 3 '16 at 15:10
  • $\begingroup$ Restarting it won't really change anything with that error message. See blender.stackexchange.com/questions/34901/… for quite similar question. $\endgroup$ – Mr Zak Aug 3 '16 at 16:28
  • $\begingroup$ What are your system specs? Please edit your question and provide more information. Either you have no graphics drivers installed, or your graphics card is to old and outdated. $\endgroup$ – Duarte Farrajota Ramos Aug 3 '16 at 18:43
  • $\begingroup$ Ok, I have added two more pictures showing more information about my computer. Please help. $\endgroup$ – Harith Aug 4 '16 at 5:24
1
$\begingroup$

Intel Q45/Q43 Express Chipsets are Legacy Products. There is no Windows 10 Support above basic for them. Basic support means "it shows stuff on screen, but as no 3D acceleration in any form".

Check out Supported Operating Systems for Intel® Graphics Products and search for "Q45" and "Q43".

In short: You won't be able to run Blender or any other Software that depends on 3D accelerated Hardware (CAD, 3D Games) under Windows 10 on this machine.

$\endgroup$
  • $\begingroup$ How cames older versions of blender are running? Would they continue to work perfectly? $\endgroup$ – Harith Aug 4 '16 at 14:15
  • $\begingroup$ Older versions of Blender aren't entirely relying on hardware acceleration. They use an older version of OpenGL that sometimes will work with pure software rendering. You may be able to sculpt basic models without high mesh density but that's it. As lemon already wrote Blender 2.77 requires OpenGL 2.1 and that is simply not covered by software rendering. $\endgroup$ – metaphor_set Aug 4 '16 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.