9
$\begingroup$

It shows this in the render mode but when in the when I try the game it has no texture. Why doesn't it show up in the game engine?

It renders like this, but when I play the game it has no texture. Why doesn't the texture show up in the game engine?

Here is the file: http://filedropper.com/textured

$\endgroup$
3
  • $\begingroup$ You could upload your .blend file using a service like filedropper.com and we could look in depth. Please update your question instead of posting additional info as an answer. $\endgroup$
    – stacker
    Dec 31, 2013 at 13:30
  • $\begingroup$ Thank you so much stacker and to all others. You guys helped me alot. $\endgroup$
    – Kyouma
    Dec 31, 2013 at 18:09
  • $\begingroup$ @Kyouma mark his answer as answered, if it solved your question. $\endgroup$ Dec 31, 2013 at 18:12

1 Answer 1

9
$\begingroup$

It seems that you haven't unwrapped the mesh. Change to Edit Mode in the 3D-View and select all A press U for unwrap.

enter image description here

In the texures settings select UV for Coordinates and UVMap as Map, Projection should be Flat by default.

Set the Viewport Shading to Texture

enter image description here

After that the texture should be shown in the Game Engine.

EDIT:

Examining your .blend shows that the texture wasn't included in the file. I replaced it with another one, the issue that the texture isn't rendered in the BGE could be fixed either by moving it into the first slot:

enter image description here

Alternatively you could set Shading to GLSL in Properties Panel N in the 3D-View in Object Mode:

enter image description here

$\endgroup$
5
  • $\begingroup$ Its still like this What should I do? $\endgroup$
    – Kyouma
    Dec 31, 2013 at 13:18
  • 2
    $\begingroup$ It seems that the current GLSL doesn't expose such problem. Removing the first slot is the key. $\endgroup$ Dec 31, 2013 at 15:07
  • $\begingroup$ I tried several options I don't know why but GLSL and Singletexture also rendered it in the BGE, multitexture seems to skip textures if an empty slot is found. $\endgroup$
    – stacker
    Dec 31, 2013 at 15:12
  • 2
    $\begingroup$ Also, BGE is currently only supporting textures of image type, not the procedural textures. $\endgroup$
    – brita_
    May 17, 2014 at 9:48
  • $\begingroup$ Looking further at Multitexture vs GLSL, for the texture to display in Multitexture, it needs to be assigned to the faces: Edit Mode > Select All , Image Editor > select the correct texture $\endgroup$
    – brita_
    May 17, 2014 at 9:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.