I spent hours on creating a background with matte textures.

No problem, they show up in the Material and the Texture view:


Everything works.

Solid view:

Solid View

Now I tried to render it and got this:

Preview Render

Pink textures all over the place. I have seriously no idea why Blender keeps doing this. I double checked all textures in the node trees, they are exactly where Blender points them at.

Here is the material:

Node Tree

but they just do not show up in the render.

I have no post-processing so far.

Here my lightpath settings:

Lightpath Settings

I hope somebody can help.

Thanks in advance!

  • 1
    $\begingroup$ Was the project moved to a different directory? Are the textures in the same place on the hard drive? Pink means that blender cannot access the files for the texture, or that they do not exist. $\endgroup$
    – user1853
    Aug 2, 2016 at 0:11
  • $\begingroup$ related: blender.stackexchange.com/questions/5368/… $\endgroup$
    – user1853
    Aug 2, 2016 at 0:17
  • $\begingroup$ also related: blender.stackexchange.com/questions/44225/… $\endgroup$
    – user1853
    Aug 2, 2016 at 0:23
  • $\begingroup$ Well, I didn't move any files, but I packed and unpacked the blend file several times during the work progress so it might've corrupted some of the paths. Thanks for the links! I'll try that out $\endgroup$
    – X_Joshi_X
    Aug 2, 2016 at 9:03
  • $\begingroup$ Well, probably the OpenGL textures for the material viewport mode are still in the video memory, while renring view tries to read them from either the Blend or the images. Did you try saving and reopening? Did you try to open image again? $\endgroup$ Aug 2, 2016 at 9:20

3 Answers 3



Apparently it has something to do with an out of memory error (since this is just a background for gigantic scene with hundreds of textures)

As you can see it doesn't render properly when all objects are visible enter image description here

But as soon as I hide every object except for example a tree that isn't rendering properly, everything works as it's supposed to enter image description here

Blender gives no CUDA errors though.. I'm really confused. I have 10GB or RAM installed and a GTX 550 ti with 1GB btw if that helps


Apparently there was indeed a CUDA out of memory error. It's fixed by just switching to CPU render.

Thanks everyone for their input!!!


It looks like the file path to your texture image is wrong/missing. Blender has the image stored in memory so you can see it in texture mode, but when you render Blender tries to look for the original image but can't find it. What you need to do is re-add your image texture to Blender so it can see the new file path.

  • $\begingroup$ The file paths are totally correct. Tried re-adding one texture. Still nothing. $\endgroup$
    – X_Joshi_X
    Aug 2, 2016 at 19:04

Pack all the texture into .blend an then put render .......

  • 3
    $\begingroup$ Please add steps so other can understand how to do this. $\endgroup$ Aug 2, 2016 at 13:18
  • $\begingroup$ Packing the textures into the blend actually isn't required to solve the problem. It worked for me in the past without doing so. $\endgroup$ Aug 2, 2016 at 13:33
  • $\begingroup$ I know how to do it since I'm not a blender beginner :) $\endgroup$
    – X_Joshi_X
    Aug 2, 2016 at 19:03
  • $\begingroup$ That's why I'm so confused. It's not just a simple "missing texture" error $\endgroup$
    – X_Joshi_X
    Aug 2, 2016 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .