0
$\begingroup$

I am having a bit of a trouble with the cycles bake. Every time i bake my texture's , a bunch of weird shadows appear in the baked textures as you can see from these pic's. The weird part is that i did pretty much the same thing to a model last night and it worked perfectly. Keep in mind that i am still just a beginner when it come's to cycles rendering.

Could this be a lighting problem or something like that?

--Before Bake--

Before Bake

--After Bake-- enter image description here

$\endgroup$
  • $\begingroup$ Is the image you are baking into itself used for the shader input ? On the left ? If yes, you may bake on another image $\endgroup$ – lemon Aug 1 '16 at 15:43
  • $\begingroup$ Well i tried your method and i still have the exact same problem. So no creating a new image to bake on didn't work. $\endgroup$ – blop Aug 1 '16 at 15:50
  • $\begingroup$ Can you upload your file here ? blend-exchange.giantcowfilms.com. With the texture if possible (pack it into the file) $\endgroup$ – lemon Aug 1 '16 at 15:58
  • $\begingroup$ I didn't allow me to upload to blend-exchange, so here's a dropbox link: dropbox.com/s/8acjg962kuv7ot8/Blender%20Sword.zip?dl=0 $\endgroup$ – blop Aug 1 '16 at 16:02
  • $\begingroup$ need to apply scale $\endgroup$ – Scalia Aug 1 '16 at 16:10
2
$\begingroup$

Dark areas on textures normally have one of the causes listed below:

  1. You have overlapping geometry
  2. You are baking combined textures, which means that you among others also bake the shadows.

According to the screenshots you provided we have both cases here.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.