0
$\begingroup$

I am currently working with a model that I made, and it is being a huge pain when trying to render the animation of it. The problem is that the texture gets extremely disrupted when any light source is added in, making huge dark streaks across the model and some places being completely blacked out. How do I fix this?enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Starting with the obvious... Would you mind telling us which render engine you are using? That would be great ;-) $\endgroup$ – metaphor_set Jul 31 '16 at 15:29
  • $\begingroup$ I am just using the default Blender Internal Render Engine (A.K.A. Blender Render) $\endgroup$ – WildHobbits Jul 31 '16 at 15:35
  • $\begingroup$ that can possibly be due to the absence of light (add some lamps to check it) $\endgroup$ – lemon Jul 31 '16 at 16:35
  • $\begingroup$ It seems to me there is only one light coming down straight from the top, add more lights or activate environment lightning, or switch to cycles... $\endgroup$ – Yvain Jul 31 '16 at 16:45
  • 1
    $\begingroup$ There seem to be several things seriously wrong with your model. One of them is Smooth Shading*, try setting shading to Flat, secondly there seem to be a lot of duplicate vertex and overlapping geometry. And from looking at the screenshot I'd risk saying you modeled all that by stacking several cubes, so there may be a lot of unnecessary internal faces. We would need to look at your wireframe model, or preferably your blend file $\endgroup$ – Duarte Farrajota Ramos Jul 31 '16 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.