3
$\begingroup$

After skinning a high density (3.6k poly) hair model to it's respective bones, I disliked the results of the automatic weight paints so I removed the Weight from each Vertex Group & used the Edit Mode method of "Select Faces > Select Vertex Group > Assign a Weight of 1" for each Vertex Group to gain precise control over which geometry the bones affect.

Sharp edges between Vertex Groups.

The result, however, are blocky deformations due to the sharp edges between Vertex Groups. I can't seem to get desirable results while using the blur tool as I don't understand how to utilize it yet. The Weight Gradient tool also appears to be finicky for me & doesn't normalize after applying it, & the Blend/Smooth tool appears to do nothing to the weights even at full factor.

Are there any tools or settings that might let me add what would otherwise be a Gaussian Blur style effect to my weights?

One work-around I've found was to use the Corrective Smooth modifier to smooth it out after-the-fact, however, I'd like to learn how to manage this within the weight paints instead of using modifiers. Will be more beneficial in future occasions.

$\endgroup$
9
$\begingroup$

Starting from this situation,

enter image description here

You can use the smooth tool :

enter image description here

  • Go in weight paint mode
  • Activate vertex selection (the little icon on the bottom of the screen indicated by a cube with one vertex in yellow)
  • Select your vertices A
  • Then in the weight paint tools panels click on 'smooth'
  • One done, go to the operator options and select 'all groups'
  • Then tune the amount of smooth you want (or click on the smooth button several times)

You need to go to vertices selection mode because the smooth operates only on a selection (unavailable if there is no selection).

By the way, few other things :

  • 3.6k is not so much at all in general for skinning. But yes, that can be a lot for this particular model
  • Automatic weights generally does a very good job and I am surprised it does not work here ? Maybe because of your bone structure as the root bone is not placed at the root of the hair ?

What I obtain with 'automatic weights' :

enter image description here

Alternative smoothing using blur brush :

enter image description here

$\endgroup$
  • $\begingroup$ Thank you so much for the help & effort. My Blender version (2.75) was the problem. It has "Blend" as what I assumed to be the "Smooth" tool. Even after creating a simple scene and following your steps, "Blend" had no effect on the weights. After checking for an update & installing ver 2.77 of blender, which does have the "Smooth" tool, it finally worked for me as you demonstrated. There are hidden Antlers & a head-piece bone which gained some of the hair weights. I felt too overwhelmed to clean so preferred starting from scratch and using the method I'm comfortable with from Maya. $\endgroup$ – Deadly Pounce Jul 30 '16 at 22:57
  • $\begingroup$ You have to be careful when using the smooth weights tool, especially with the Subset option. Leaving it to "All" (smoothing vertices from all groups) has the side effect of "expanding" the influence of a group where it shouldn't have. A single blue vertex will expand to cover all selected vertices. Therefore, it's always better to use the "Selected Pose Bones" subset and different Source modes ("only deselected", "only selected" and "all") depending on what you're trying to do: to smooth within a vert selection, to bridge between different areas etc. $\endgroup$ – R. Navega Nov 17 '17 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.