-1
$\begingroup$

I'm currently using shadowplay to record gameplay and audio while my brother uses mumble to record our voices. I use blender for my editing, just started within the past couple weeks so still new to how it works, but I'm having trouble getting everything to line up. Why is it that when I first load each file into blender everything seems to match up and sync properly, but before saving a final video, it saves it at 10fps? If I change it, it completely alters the sync between both audio files and the video file.

I have the AV sync option chosen as well.

$\endgroup$
  • $\begingroup$ Are you referring to playback before rendering? Please read this: blender.stackexchange.com/a/48038/1853 $\endgroup$ – user1853 Jul 29 '16 at 1:45
  • $\begingroup$ Yes. The playback gets out of sync when I change the fps to speed up the rendered video so its not incredibly slow. $\endgroup$ – Xain Jul 29 '16 at 1:50
  • $\begingroup$ Just don't. Blender is not a time-based video editor. It is frame based. Frame based: After Effects, Fusion, Blender, Nuke,.. Time based: Final Cut Pro, Premiere Pro, Movie Maker :), .. you want to cut your videos with these. $\endgroup$ – Jaroslav Jerryno Novotny Jul 29 '16 at 14:26
  • $\begingroup$ Check out Lightworks: lwks.com it's free. $\endgroup$ – Jaroslav Jerryno Novotny Jul 29 '16 at 14:31
  • $\begingroup$ Add Resolve to the list of editors . There is a free version. $\endgroup$ – user1853 Jul 29 '16 at 17:34
1
$\begingroup$

The codec that you recorded the screen cast with may be difficult for Blender to playback. Try making a "proxy with timecode" first. This should help nail down the drifting sync issues.

  1. Select the strip of your screencast and hit N key for the properties panel.

VSE Proxy in properties panel

  1. Then scroll down to the Proxy/Timecode tab and turn it on.
  2. Then toggle the Timecode: option menu and select 'Free Run'.

Turn on timecode

  1. Then hit the button "Rebuild Proxy and Timecode Indices".

Some codecs actually have a variable frame rate, meaning that Blender may not play them correctly. I suggest that you transcode (make a copy using another codec) that is more blender friendly. While Blender may do it properly, your best bet is using an external application like ffmpeg where there is more control of the settings.

Blender prefers Frame Sequences but they are not well compressed. You can use a lightly compressed h264 stream as well but you will still have to generate proxies. Other editing applications tend to do this automatically anyway.

Remember to increase the memory allocated to the VSE or Sequencer in the user prefs.

User prefs sequencer

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.