4
$\begingroup$

I am new to blender and I tried to animate a camera path following this tutorial: https://www.youtube.com/watch?v=vasfFsxCsAE

The author creates a NurbsPath for camera to follow and an empty to specify the focal point. However, things don't go to plan for me. First, after inserting the path and making the camera follow it, I use Ctrl+A to apply location, rot and scale, as recommended at 6:33, but I get a "Objects have no data to transform" message. I don't know which effect it will have on the animation, but it doesn't seem good.

Also, during the animation the camera is often diagonal to the ground, I also tried to use Twisting->Z-up for the NurbsPath as suggested at 5:50, which doesn't have the effect I expected, the camera still stays diagonal. Then I tried to add "Limit rotation" constraint to the camera. Now it stays parallel to ground plane, but instead flips 180 half way through the path and then flips back.

Additionally, when I add an empty, move it to the point I want and do Ctrl+A to apply the location as suggested at 7:07 my empty actually moves to a different location, which doesn't happen in the video. So it looks like something is wrong with my coordinate system.

Could anyone help me to resolve these issues?

The file is here, I got the model from blendswap.com, it is made by aXel.

$\endgroup$
  • $\begingroup$ I think I have reproduced part of your problem, but could you upload your file here ? blend-exchange.giantcowfilms.com ? Also can you try to add a vertex in the nurbs path, just to check if the camera flipping problem is still there after that ? $\endgroup$ – lemon Jul 28 '16 at 14:33
  • $\begingroup$ Ok, I edited the question to add the file. $\endgroup$ – Noidea Jul 28 '16 at 14:54
  • 2
    $\begingroup$ Try using track to (as opposed to limit rotation and damped track) i.stack.imgur.com/vgCf2.png $\endgroup$ – cegaton Jul 28 '16 at 15:44
  • $\begingroup$ thanks @cegaton, it works. But I am stuck on a curious behavior.. will add a question about that. $\endgroup$ – lemon Jul 28 '16 at 16:06
  • $\begingroup$ thanks @cegaton, works for me too! I think it wouldn't happen if it was interpolating in quaternions and not in Euler angles. $\endgroup$ – Noidea Jul 28 '16 at 16:17
0
$\begingroup$

Nice car, that's my favourite one... so applying scale of the curve doesn't helps.

That was just a guess, I already thought that my idea wont work....

So well, your curve flows like that: sometimes the curve is over the handles and sometimes under them. On the place were the cam switches, the curve is at two places over the handles (so like Adrian Monk would Say it's not perfectly symmetric...) I checked with the fishbones the directions of your curve, but it looked okay...

Sometimes I'm a bit confusing, sorry for that!

$\endgroup$
  • 1
    $\begingroup$ can you edit this? I'm having a hard time understand the last part of your answer. Remember when writing an answer you should not only be thinking about the OP but everyone that will see this. $\endgroup$ – David May 28 '18 at 21:05
  • $\begingroup$ Be aware that this is purely a question and answer site, it doesn't work like a forum. Answers are only used to give a full answer to the question asked, not to discuss it. It sounds to me like you are talking about things you tried with the file when you downloaded it? $\endgroup$ – kim holder May 28 '18 at 21:17
  • $\begingroup$ Yes, I also rewrote my post to make it better to understand... I should go to bed now ... :-D $\endgroup$ – M. Matz May 28 '18 at 21:24
0
$\begingroup$

Remove the constraints currently on the camera and use a "Track to" constraint instead, as shown below:

Track to constraint

The camera is initially tilted because the curve is a slope. The "Damped track constraint" doesn't rectify this because it only performs the minimum necessary rotations to have the object face the target. The flip occurs because of limitations with the actual "Limit rotation" constraint; it only works from -180° to 180°, anything outside of that range results in flipping.

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.