1
$\begingroup$

I created several planes scattered around the scene, but I created them individually.

I also extruded several planes to create an expanding curve, without realizing that I was scaling on two axes at the time (for each new plane). I would have preferred to only scale the 'y' value, but I didn't notice my mistake in ortho view.

Is there a way to change all of their size values to be equal? Let's say I want them all to be 1cm X 1cm, but they are all currently slightly different sizes. I don't want to change the position or rotation of any of them though.

Thanks for the help, I'm just getting started in the 3d world.

$\endgroup$
6
$\begingroup$

Just press the Alt key before clicking any of the value text boxes and inserting you values.

That will affect all selected objects instead of just the active one. It will also work for modifiers and most other properties.

Multi Editing

Edit

If all your planes belong to the same object you have to separate them before controlling sizes directly, since absolute size control will only work in Object Mode, not Edit Mode.

  1. Enter edit mode in your planes object
  2. Select all with A
  3. Separate all planes with P > Loose Parts
  4. Now exit edit mode
  5. Select all separated plane objects
  6. Move their object center to the center of the geometry so their positions wont change when you change their scale, by pressing Shift + Ctrl + Alt + C > Origin to Geometry
  7. Now you can change size

Don't forget to apply transforms afterwards with Ctrl + A > Scale

$\endgroup$
11
  • $\begingroup$ Thanks Duarte. That does help with half of the problem. It works great with the separate objects I created. I can't get it to work with the multiple planes that I extruded though. I've tried selecting faces and edges, but I can only get the dimensions in object view. Then it just ends up scaling the entire object (all of the edges and faces) proportionally, instead of resizing everything to the same 'y' value. I am willing to start from scratch, but I would just like to know if my problem is possible to solve in blender, for future reference. $\endgroup$
    – TinySharks
    Jul 28 '16 at 5:12
  • 1
    $\begingroup$ @TinySharks The Alt key doesn't work for me, (ubuntu disabled as HUD still no joy). You can also set the dimensions of your active object to (1,1,0) right click and "Copy All to selected" to make all selected objects have the same dimensions. $\endgroup$
    – batFINGER
    Jul 28 '16 at 7:14
  • $\begingroup$ @TinySharks You don't need to start over, you just have to separate the objects first. See my updated answer above on how to. $\endgroup$ Jul 28 '16 at 15:21
  • $\begingroup$ @Duarte, Thanks for the update. The process makes complete sense, but I'm having issues with separating extruded planes. I was able to use your method with complete success when using a subdivided cube, but not with extrusions, for some reason. I even made a plane and extruded it twice, just to see if my original object was too complicated. I couldn't separate by loose parts in that one either. I can separate anything by selection just fine, it's separating by loose parts that isn't working with meshes created with extrusions. $\endgroup$
    – TinySharks
    Jul 29 '16 at 1:42
  • $\begingroup$ Are you sure it's not working, there's not much that can go wrong. Separating by loose parts works on meshes composed of several separate chunks only. If your planes are somehow connected it wont work. Otherwise if you are still having trouble edit your question and a link to post your file so we can look at it. Afterwards be sure to poke my user name with @duarte-farrajota-ramos so I get a notification $\endgroup$ Jul 29 '16 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.