1
$\begingroup$

When I was editing a model in solid mode, the properties window refused to adjust correctly; every time I pulled it closer to the edge of the blender window it would take up more space, the opposite of what it had done before.

While I was trying to adjust the size of the properties window, an unresponsive black screen appeared. The screen took up more than half of the window.No matter how many times I close and reopen the model I was working on when the error occurred, the screen remains unresponsive. Before closing the file for the first time after the black screen opened, I saved my progress.

The screen seems to show the image of the last blender file loaded after opening that particular blender window.

All other blender files work just fine; this is the only one that has this issue.

The after loading a new file and then opening the erroring file

The error after directly opening the erroring file

$\endgroup$

2 Answers 2

1
$\begingroup$

Open a new instance of Blender without opening any file, go to File > Open search for your file but before you open it untick the Load UI box at the bottom left of the File Browser editor.

Then open your Blend file, see if that works.

After successfully opening it Save As with a different file name.

You should probably submit your original corrupt blender file as a bug report in the bugtracker with a complete description like the one provided in your question, because it sounds like an issue that can produce corrupt .blend files that fail to open causing potential data loss.

In the future if you want to prevent this from happening you can make Blender never load the UI from other files bu unticking the Load UI option in File > User preferences > File > Save & Load > Load UI

$\endgroup$
0
0
$\begingroup$

I had a similar, but different issue. Blender opened, but froze with a blank screen before the splash screen, no file loaded, and Blender wouldn't close until I used xkill (Alt + F2 => xkill => click).

I fixed it by editing the blender.desktop file (/usr/share/applications/blender.desktop). Near the last line in the blender.desktop file, I changed PrefersNonDefaultGPU=true to PrefersNonDefaultGPU=false.

It seemed to be related to recently changing the NVIDIA GPU driver.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .