4
$\begingroup$

Hi I am trying to add a a cylinder pattern on the faces of the icosphere.(image 1)

Image 1: image 1

thought tissue addon might work but can't get the pattern to sit correctly on sphere (it gets squashed see image 2)

Image 2: Image 2

However I have tried individually extruding the faces of the icosphere, then scaling down, subdividing edges... but can't find a way of making each one of those faces circular (so I can extrude then all out to make the cylinder parts jut out).

In reponse to answer..This is happening ..what am I doing wrong?First Image belowimage 3

$\endgroup$
4
$\begingroup$

It should be achievable with Tissue add-on.

enter image description here

Make sure the normal's of your objects are correctly ponting outward. In your image they are not in the component object (you can see it from the dark blue tint of the faces). I'll suggest to check the orientation by enabling the Normals checkbox in the Mesh Display Panel. But that's not what prevents you from obtaining a good result.

From your images it seems that the adaptative geometry is collapsed on the Z-axis. Try to keep the value away from the 0, and also check the rotation of the component: the add-on is expecting a shape developing on the Global Z axis.

Dont' forget to pick the objects in the correct order and leave Quad mode in the settings.

enter image description here

Note that as tris based adaptation is currently not supported, you'll encounter some deformation on the cylinder. A possible alternative that would not led you to a component distortion could be Duplifaces:

enter image description here

You should perform a "smart" remove doubles in order to get rid of the spaces between the duplicated component (Dupliface it's not adaptative as Tessellate is).

enter image description here


About your last pick, I may guess your component has some loose geomerty that is altering the overall boundary. As all the geometry is taken into account, the space beteween the componeent and the vertex, will be reproduced too.

enter image description here

$\endgroup$
  • $\begingroup$ i have tried it but it is only covering parts of the sphere with geometry.photos on edited post $\endgroup$ – Sarah O Neill Aug 12 '16 at 11:02
  • $\begingroup$ Probably your component object has some "flying" geometry, like a lonley vertex somewhere, that alter the overall bounding box and lead to the wrong result. Give it a check. If you can0t find it, I would suggest to upload your testfile to blend-exchange.giantcowfilms.com. $\endgroup$ – Carlo Aug 12 '16 at 17:22
  • $\begingroup$ I have same problem i have posted the question blender.stackexchange.com/questions/94292/… $\endgroup$ – atek Nov 13 '17 at 12:15
4
$\begingroup$

I'm the developer of Tissue. In order to create a symmetrical cylinder I suggest to use FAN mode, using instead of the full plane+cylinder component, just a third of it, like a single petal.

enter image description here

Anyway, it will not be perfectly cylindrical.

Alessandro

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.