11
$\begingroup$

Whenever I try to cut out a circular hole in either a cylinder or sphere the polygons around the circular hole always have distorted normals after smoothing. Is there anyway to fix this. I've tried using the remesh modifier but wind up with some pretty ugly results.

After selecting faces and converting to a circle using Loop tools.

$\endgroup$
1

4 Answers 4

10
$\begingroup$

you could use the Knife projection (in front mode of the circle ) enter image description here select your cylinder and your circle go into edit mode of your cylinder and click while you are in Edit mode in the T-panel on Knife Project

$\endgroup$
1
3
$\begingroup$

Enable LoopTools via menu EditPreferencesAdd-onsLoopTools:

Enter image description here

In Edit Mode, press 3 to switch to Face Select mode and select a square area of faces where you want the circle to be. Click RMB > LoopTools > Circle. Make sure you uncheck Flatten in the Adjust Last Operation panel that appears in the lower left corner to avoid distortions on the curvature of the cylinder. I recommended to inset with i and to add edge loops.

enter image description here

$\endgroup$
0
0
$\begingroup$

I think not the cutting but the smoothing is the problem. So perhaps you need a way to cut the hole so you don't need to.

This is what I get when I use the Boolean modifier and apply it:

enter image description here

$\endgroup$
0
$\begingroup$

you need another circular edge loop on the surface of the cylinder just outside the hole(like the ones used to bevel a subsarfed edge), if you used the knife project tool , you can try and redo the operation with the circle slightly scaled up.

$\endgroup$
1
  • 2
    $\begingroup$ Could you maybe add a screenshot of what you mean? $\endgroup$
    – PGmath
    Oct 26, 2015 at 13:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .