3
$\begingroup$

I'm currently modeling a Red Panda for animation I am doing and I am having trouble rendering the hair. My model looks like this- Original Panda

The render looks like this- enter image description here

These are my nodes:

enter image description here

And here are the particle settings-

enter image description here enter image description here enter image description here

What do I do? I've only been using blender for a few months so most things are new to me because I am only 14 years old. All answers are much appreciated. My intentions for this is to make a continuous flowing fur on the Red Panda in order to produce a seamless effect when animating and rendering the final product. I do not want a spotty fur coat with missing patches. After rendering, the object mode view of the panda is all messed up and the hair is sticking up in all different directions (see below) instead of the way I had it combed. When I press undo (Ctrl+Z) it goes back to the way I had it before.

enter image description here

$\endgroup$
  • $\begingroup$ We do not see the same size of your panda...but I believe both are the same, am I right ? $\endgroup$ – lemon Jul 24 '16 at 17:40
  • 2
    $\begingroup$ Welcome to Blender.SE! Could you spend a few word describing what exactly don't satisfy you at the moment? I know it may seems obiuouvs to you, but it may be not. Just to be sure. Please add here in the comment the links to screenshot showing the shader's node and the particles 's system relevant settings. $\endgroup$ – Carlo Jul 24 '16 at 17:43
  • $\begingroup$ @lemon, you are right $\endgroup$ – Jacob Lurie Jul 24 '16 at 18:00
  • $\begingroup$ Not sure bu it looks like there may be a normals issue with your model. Have you tried entering edit mode selecting all faces and recalculate normals with Ctrl+N? $\endgroup$ – Duarte Farrajota Ramos Jul 24 '16 at 22:48
  • $\begingroup$ @DuarteFarrajotaRamos I tried what you said and still the same spotty result $\endgroup$ – Jacob Lurie Jul 25 '16 at 0:28
6
$\begingroup$

Whenever it comes to differences with particle systems between preview and final render it almost always has something to do with the subsurf modifier.

  1. Always make sure that you have the subsurf modifier enabled in Render and Preview mode when you use "Particle Edit" (cut, comb, etc.). I believe that you had it turned on, when you combed the hair, since it is activated in your file (see image below)

  2. Always set the viewport and render settings to the same value when rendering particle systems. If the render setting is lower than the viewport setting (which is the case in your file, see image below) the render process will undo or at least mess up your combed hair.

view differs from render

Try to set the viewport subdivs to 2 and you'll get the same messed up hair effect you had after rendering.

Set the Render subdivs to 3 and your problem should be gone.

$\endgroup$
  • $\begingroup$ Thank you so much. This worked!! Your help is much appreciated $\endgroup$ – Jacob Lurie Jul 25 '16 at 17:43
  • $\begingroup$ Glad I could help. Could you mark my answer as accepted, please? Thx. $\endgroup$ – metaphor_set Jul 25 '16 at 18:49
  • $\begingroup$ @jacob-lurie Please mark an answer as accepted if it solved your problem, or at least consider upvoting it if it helped you $\endgroup$ – Duarte Farrajota Ramos Jul 26 '16 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.