2
$\begingroup$

I am having a problem with a material/texture not showing up transparent as it should in blender 2.69. The material is from a tga file. I have a video showing the problem here where the hair should be mostly transparent, but instead shows the default model color of gray.

It looks like it should when I right click on it, but when I select a different part of the model, it show incorrectly again. I followed the steps in this tutorial and it got it so that it works when it is highlighted at least which is a nice, but it is still not working as can be seen when some other part is selected.

The blend file can be found here. Thank you in advance for any help that can be offered.

$\endgroup$
1
$\begingroup$

Tick Transparency under Display in the Object tab. This will have the object's material display any transparency it has in the viewport sans the gray placeholder.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hm, it seems that this doesn't fix the problem with the official 2.69 release. I notice that I have a slightly different layout in the display panel (Type is labeled Maximum draw type and in one row with Object Color), are you using a nightly build? $\endgroup$ – stacker Dec 29 '13 at 10:33
  • $\begingroup$ @stacker I was using 2.66, the panel has just been reorganized and I tested this in the latest and the official build of 2.69 and it works. It hides the outline by default so you might have to enable Wire or Bounds to select it easier after. pasteall.org/blend/25944 $\endgroup$ – iKlsR Dec 29 '13 at 16:48
1
$\begingroup$

If iKIsR's solution doesn't work for your case, you may then try to tweak the OpenGL Clip Alpha value in User Preferences window to fix the display in certain cases.

The "gray" color on the hair is the 3D View background color, not the model color. Besides, I know you are talking about the 3D View display issue, but the current hair cannot be actually rendered as trasparent, btw. You need to uncheck the Face Texture Alpha in Options panel, and check the Receive Transparent in Shadows panel. Hope it helps anyway.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.