0
$\begingroup$

I have been trying to align objects along a curve only pointing along the Z-Axis. I found i could accomplish it using DupliVerts and checking rotation, but because the mesh only has two verts, it doesn't know where to point the objects.

Normals Aligned

enter image description here

I can fix the problem if i extrude the mesh upwards, but i don't want to do that because now i have two sets of mesh.

enter image description here

enter image description here

Does anyone know how to force Blender to point the normals in one direction? Any help would be awesome!

$\endgroup$
1
$\begingroup$

Place the pillar at the beginning of the curve, be sure to apply rotation and scale (or at least have an alignment relative to the world or the object itself, locally) :

enter image description here

Parent the pillar to the curve, and set dupli as frames (uncheck the speed button) :

enter image description here

For the curve, set it to path animation tunes the frame count (it will be the amount of pillars) and check 'follow'.

enter image description here

Now add a constraint to the pillar to 'limit rotation', and check the wanted axis (here Y). So the pillar will follow the curve without rotating around this axis.

enter image description here

$\endgroup$
  • $\begingroup$ You are amazing Lemon! I had no idea what the frames option was and made the whole process simpler! Thanks for taking your time to help me. $\endgroup$ – Ryan Grzesiak Jul 23 '16 at 22:28
  • $\begingroup$ One fun fact for anyone reading, if you turn the twisting option in the curve settings to "Z-Up", it keeps the pillars straight when re-positioning the curve! $\endgroup$ – Ryan Grzesiak Jul 24 '16 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.