4
$\begingroup$

Is there anyway to help avoid accidentally relocating the 3d-cursor?

You have all of these complex keystrokes in Blender like (CTR+ALT+SHIFT+C), but yet all it takes is a simple accidental left mouse button click to re-locate the cursor. How many hundreds of times I have done this and then had to move the 3d-cursor back where it was. Moving the 3d cursor is not stored in the Undo buffer, so you can't "undo" a relocation of the 3d cursor. It is very frustrating.

$\endgroup$
  • 4
    $\begingroup$ depends on where you want to have the cursor. Try shift+c to set it back to the center. $\endgroup$ – metaphor_set Jul 22 '16 at 15:41
  • $\begingroup$ Added my own answer, see below. $\endgroup$ – TTTTTTa Jul 22 '16 at 16:05
  • 1
    $\begingroup$ Related - blender.stackexchange.com/questions/21800/undo-cursor-move. It is told there about undoing while yours is about preventing, still it can be useful $\endgroup$ – Mr Zak Jul 22 '16 at 16:44
  • $\begingroup$ Ok, that is a useful link. I just changed the title of the question from "Preventing moving the 3d cursor?" to "How to avoid accidentally relocating the cursor?". Because, it seems it is not possible to "Lock" the 3d cursor in blender. So the answer below now agrees with the question. $\endgroup$ – TTTTTTa Jul 22 '16 at 16:51
4
$\begingroup$

I saw the same question with solution from a long time ago: http://blenderartists.org/forum/archive/index.php/t-236492.html

I went to the user preferences and switched "Set 3d cursor" from "LMB" to "Shift + LMB". Now I can no longer accidentally move it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.