0
$\begingroup$

I'm planning on selling asset's in unity and they need to be in .fbx or .obj form and cannot be in .blend. When i export the project in .fbx their scale is different, in blender the scale says "1" and in unity the scale says "100" and when i export the project as .obj the all of the models merge into one.

In here the scale says 1.

In here the scale says 100 and when I put the low poly trees in the tree editor in unity the scale of them is to small.

And when i export it as .obj it merges all the models. enter image description here

Any help is appreciated, thank you.

$\endgroup$
1
$\begingroup$

There are a couple ways around this:

  • Split your .blend files: This is probably the best thing to do anyway, since you seem to be using Unity's automagic importer. This will allow Unity to conceptually separate your meshes into their own discreet thing, and if you change them, the changes will propagate correctly.
  • Split through prefab: You can take the multi-tree model, delete all the meshes down to one tree, and save those changes as a separate prefab. This has issues though, mostly because if the file change noticeably, you will need to redo the prefab.

Scale is mostly arbitrary, but you can change Unity's import scale by clicking the model in the assets browser, then going to the inspector and playing with the Scale Factor (top line).

$\endgroup$
0
$\begingroup$

Unity and units:

First and foremost the unit thing is and always will be a problem. I can't give any advice about how to do a "proper" scaling, besides trying out what fits best.

It might help if you switch to actual units instead of Blender's default setting (no units). In the properties window switch to "scene view" and there chose "metric". You can also chose a different scale here.

Properties window, scene chose Units

Exporting to obj:

Exporting to obj with default settings will always export the whole scene. You'll have to select the model in object mode, then change the settings in the export window at least to "selection only". If you have active modifiers that you want to have in the final model you should check "Apply Modifiers", too. I don't know much about unity's import function but I never had a single case where I could reuse Blender's exported obj materials. I always keep that one unchecked.

enter image description here

$\endgroup$
0
$\begingroup$

Thank you for your answers but i found another and in my opinion, better answer myself.

When saving it in .fbx you need to change the version to the one shown in the image below and regarding the rotation of the object set the factors to Z-Forward and Y-Up and then export the file and inside the unity engine set the default scale to 100 like in the image below. enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Instead of scaling in Unity by 100, you can scale in the fix exporter by 100. $\endgroup$ – Gliderman Jul 20 '16 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.