1
$\begingroup$

When I press I in the Action Editor (with a bone selected in Pose Mode and no keying set selected), the Insert Keyframes menu that appears does not contain all of the normal options like Location, Rotation, Scale, LocRot, etc. Instead it only contains 3 options: All Channels, Only Selected Channels, and In Active Groups. Selecting any of these options yields no results (not even an error message) other than the file size increasing slightly.

In the screenshot below, I've adjusted the rotation and scale of a bone and attempted to add a keyframe to the current action to illustrate what I'm talking about:

enter image description here

I've tried changing the keying set to rotation and scale but the results were exactly the same.

As a bonus, it would be nice if I could figure out what exactly was happening that increased the file's size when I clicked on those three options so that I can undo it!

I'm fairly new to Blender, but I've been able to animate a few characters now without running into this issue before. I'm not sure what I did differently this time, but hopefully I can avoid whatever mistake I made in the future!

$\endgroup$
1
$\begingroup$

I'm not sure about the file size but that is the correct menu for the dope sheet editor. For the full menu press "i" over the 3d view instead.

enter image description here

$\endgroup$
  • $\begingroup$ Wow, yup, that's all it was! Don't I feel silly. ;) Just part of the kinks of learning new software, I suppose! $\endgroup$ – Clément Todd Jul 19 '16 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.