1
$\begingroup$

blender boost version?

have problems incorporating dlib with blender (2.77a)

hello, My name is pascal and i am having trouble installing dlib with blender. Dlib is a model that uses boost to do lots of cool things. What I’m interested is the capableilty of extracting facial points from a webcam. This means i can control any blender rig on any computer using any webcam… Well if i could get dlib working.

  1. I have tried building blender 2.77a from scratch on my computer
  2. i have tried taking out blenders python and inserting my own
  3. i have tried a simply sys.append() to the python system folder that has dlib in it

created a python 3.5.1 for 1 and 3 in order to recognize my own python. I had to do sys.append() which then worked and imported everything that did not use boost. for 2 worked for all but boost library without needed to create python paths.

so this is what it looks like when it crashes or gives me an area

import dlib  #this works

import os
predictor_path = "/Users/pascaljardin/Desktop/TheBitcoinDimension/CodeStuff/shape_predictor_68_face_landmarks.dat" #need this to be installed on desktop

print(os.path.exists(predictor_path))
    Code output: True

dlib.shape_predictor(predictor_path)

# Code output:  
#   Traceback (most recent call last):
#     File "<blender_console>", line 1, in <module>
#   TypeError: __init__() should return None, not 'NoneType'

This is where i receive this error or blender will completely crash. As i understand the reason why importing lib worked is because it was able to find the links to call it. But when it wanted to actually run something, the boost got all messed up… well thats my understand any way

Here is what i installed in order to get the facial points and something in this is not happy with blender 2.7. Everything need for dlib to work: installed on python 3.5.1, but can us any python 3.x

 boost:  1.59.0-py35_0 menpo
 bzip2:  1.0.6-3            
 dlib:   18.18-py35_2  menpo
 libpng: 1.6.22-0           
 mkl:    11.3.3-0           
 numpy:  1.11.1-py35_0  

with that said, i can use the sys.append() to another python environment and by doing so dlib can be used in that environment

so do i need to build blender form scratch a special way for this to work?

Or do need to use a older blender like 2.6 for this to work Because the python version dose not matter to install the dlib, as long as its python3x

or better yet is their a line of code that will magically get dilb working?

Thanks, Pascal

$\endgroup$
3
  • $\begingroup$ If you look at the libs used to build the blender releases you will see that boost 1.60 was used. I also think blender includes numpy 1.10.1. Start with matching lib versions, as blender has boost loaded it will use that and not load the version you expect, which you compiled dlib with. The other option to try is building blender yourself, not sure what boost options are linked into the included boost, it may be missing the code you need to use dlib. $\endgroup$
    – sambler
    Jul 17, 2016 at 12:25
  • $\begingroup$ thanks, I understand now that the boost was the wrong version. Therefore blender couldn't read dlib. Now I'm using a different environment with the correct boost.... but now i don't know how to install dlib! $\endgroup$ Jul 18, 2016 at 17:00
  • $\begingroup$ Dose anyone now how to create an python3.5 environment with dlib and boost 1.60 ? $\endgroup$ Jul 18, 2016 at 17:01

0

You must log in to answer this question.

Browse other questions tagged .