7
$\begingroup$

I'm having this weird problem with my camera in which I can only render from a certain position that is not the one on the camera. It's like the view got detached from the camera and I can't change it. I can't manipulate it and it always renders in that position. Deleting the camera makes no difference, and there is no hidden camera in the file. It's not the first time I've had this problem.

Sorry, I can't upload the file since it is now too big.

----SOLVED-----

What happened is, I somehow put another object as my camera.

I solved it by going on Scene Settings (third tab on the Properties window), one of the first fields asks for the camera (and there I had a plane).

Thanks to eromod for pointing out any object can e a camera in Blender.

$\endgroup$
  • $\begingroup$ Please edit your question and add an image of your screen. $\endgroup$ – user1853 Jul 16 '16 at 23:42
  • $\begingroup$ Do you have any keyframes in the scene? $\endgroup$ – user1853 Jul 16 '16 at 23:56
  • $\begingroup$ Please do not place the solution in the question. If you have a different answer, please add it down below (or maybe add a comment to an answer that worked for you, noting the changes you needed). Thank you! $\endgroup$ – Gliderman Jul 17 '16 at 1:28
4
$\begingroup$

You must have set the object as the "active camera".

In Blender even a mesh can be a camera.

There is a bunch of ways to change it but the shortcut is to select the new

camera and Ctrl+ Numpad 0

How can I make a camera the active one?

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you very much, I had no idea this was possible. $\endgroup$ – Douglas Rosa Jul 17 '16 at 0:06
  • $\begingroup$ no problem, I knew that because I read it in the Blender Reference Manual. Its my new years resolution, this year, to finish reading it. Im well on my way. blender.org/manual $\endgroup$ – eromod Jul 17 '16 at 0:13
2
$\begingroup$

Camera also locks when a keyframe is enabled on the camera. Solution is to either remove the keyframe, or adjust it on the keyframe if you need. Had this issue and an answer to the OP helped me.

| improve this answer | |
$\endgroup$
  • $\begingroup$ i had this issue too. the viewport show the correct view but it the render to the first keyframe, the solution is to add new camera $\endgroup$ – risnandar Apr 26 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.