1
$\begingroup$

I just started blender and one of the main things you have to do is to render to make an animation, but I can't seem to do that. Whenever I click Render and then render image or render animation, at the top of the screen it says 'No camera found in Scene "Scene". I don't know why this is happening.

$\endgroup$
1
  • 1
    $\begingroup$ What is happening is exactly what Blender is telling you that is happening, No camera found in Scene Scene that means there is no camera object in your scene, so go about creating one as described in Shubol3D answer. $\endgroup$ Commented Jul 16, 2016 at 17:50

6 Answers 6

7
$\begingroup$

I don't know any other reason, except you have no camera in your scene.

You can add a camera by: Shift + A > Camera.

Or maybe you have a camera in you scene, but it is switched off for render. Check the little camera icon on right side in Outliner.

There are Eye for visible in viewport, arrow to prevent selection, and a Camera to toggle visibility in render.

$\endgroup$
1
  • $\begingroup$ Please consider making the answer as correct if it solved your problem, or at least up voting it if it helped you. $\endgroup$ Commented Jul 16, 2016 at 17:54
4
$\begingroup$

I found another place to check that sorted my 'no camera' error. Check the camera setting in 'Scene' tab in the 'Properties' panel. Mine had nothing in it! Even though I had a camera in my scene

Properties Panel, Scene Tab

$\endgroup$
4
  • $\begingroup$ That is not unusual. You can have a camera, or many cameras that are in the scene, but not set as the scene camera. (An object can be set as the scene camera.) $\endgroup$
    – David
    Commented Jul 2, 2017 at 13:03
  • 1
    $\begingroup$ I have the same problem, but there IS a camera, and it IS set to render, and it IS set as the scene camera. Still can't render my image, and still get the "No camera in scene" message. $\endgroup$ Commented Dec 6, 2019 at 0:24
  • 1
    $\begingroup$ It turns out that if you have multiple scenes in a blend file, each scene has to have a camera. $\endgroup$ Commented Dec 6, 2019 at 0:31
  • $\begingroup$ @PhilRogers Thank you! Same thing happened to me. The error message really should be reworded to something like: "All scenes require an active camera." $\endgroup$
    – Mentalist
    Commented Aug 23, 2022 at 9:29
0
$\begingroup$

All you have to do is press add at the bottom left corner of the blender screen. when you have finished clicking add, press camera at the second top of the options menu.

Press add at the bottom left corner of the timeline editor.

Now all you have to do is press camera.

Thank you for listening to my simple tutorial!

It is that easy. :)

no camera found in scene "Scene"

is the problem to your question.

$\endgroup$
0
$\begingroup$

If adding a camera to your scene and setting it as the scene camera, the next thing to check is whether you have multiple scenes in your blend file. if you do, you have to have a camera in every scene.

$\endgroup$
0
$\begingroup$

i found couse of error. In actually when we save startup file then unnecessary scean which appended or link by us is become problem for new project or file so go to outliner> blender file> search unwanted scean and delet it.

$\endgroup$
-1
$\begingroup$

I reproduced this error in Blender v3.2.0 because I had renamed my camera to 'ScoutCam'. Rendering ran properly when the camera name was left as 'camera'.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .