0
$\begingroup$

I'm changing an animation simple youtube intro from 24fps to 60fps. The music in the intro plays at the right speed but the animation only lasts for the original time and hasn't changed its length with the new frame rate. So it is rendering what appears to be VERY QUICKLY while the music it was matched to is still playing I have a black screen because the animation is over. Is there an easy way to have the time of animation match the time the audio takes to play?

$\endgroup$
0
$\begingroup$

You'll need to scale the keyframes of all animated elements in the scene so the last ones end at frame 60.

  1. Open the dope sheet editor and place the cursor (the green line) at frame one.
  2. Select all the diamonds on the dopesheet so that they are all orange
  3. Press S to scale and stop when the diamonds on frame 24 reach frame 60. Left Click to confirm.
$\endgroup$
  • $\begingroup$ THANK YOU!!! There really should be a simple function IMO built into Blender to scale this with FPS. Not on by default even, but as an option. $\endgroup$ – Charles Green Jul 15 '16 at 18:23
  • $\begingroup$ Yeah, perhaps. I think it is actually a bit uncommon for people to switch frame rates after a project is finished, but I can understand wanting it as a feature. $\endgroup$ – HowToBlend Jul 15 '16 at 19:30
0
$\begingroup$

One option is to use the Time Remapping option in the Scene>Dimensions of the Properties. Since your scene is keyframed at 24 FPS you would set Time Remapping Old: 24 and set New: 60. You will have to alter your Start and End Frame to match the new 60FPS rate. So an animation that used to have 120 frames at 24 FPS will have to have 300 frames at 60 FPS.

Scene > Dimensions UI

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.