7
$\begingroup$

This is what I have so far:

enter image description here

http://imgur.com/a/ZnFOt

The rendered image has a transparent background, but the glare filter creates an output with a black background, so after merging the two togheter, the background turns black but I need it to be transparent, what can I do?

$\endgroup$
  • 2
    $\begingroup$ I don't think that the Glare node is specifically involved in this kind of issue. It should use the source image's alpha channel already. Seems instead that you unchecked the "Use Alpha" box in the Composite node. Try to re-enable it and let us know if the problem persists. $\endgroup$ – Carlo Jul 14 '16 at 0:05
  • 1
    $\begingroup$ @tacofisher you are not using the alpha at all, connect the renderlayer node's alpha output(first node) to the composite node's alpha input(last node). $\endgroup$ – user2816 Jul 14 '16 at 0:10
  • $\begingroup$ Ok, thanks both of you for your help, now the background is transparent but I have another problem, the glare remains within the chains and the yellow beam, but doesnt "smear" to the rest of the picture (the black part of the picture) $\endgroup$ – tacofisher Jul 14 '16 at 0:45
  • $\begingroup$ Use alpha over instead of color mix. And then read this post: blender.stackexchange.com/a/44137/1853. The glow over the transparent cannot be displayed in the render viewer. Your image is fine if you comoposite it over a different background. $\endgroup$ – cegaton Jul 14 '16 at 0:46
  • 1
    $\begingroup$ As long as you do the compositing in blender you should be fine. Read the answer. $\endgroup$ – cegaton Jul 14 '16 at 1:25
13
$\begingroup$

Use Alpha Over to composite the two images:

enter image description here

To have transparency enable "Use Alpha"

NOTE that if you try to display the image on the render viewer using RGB+Alpha you won't see the correct results.

enter image description here

enter image description here The glow information is there, you just can't see it, enter image description here

The viewer is broken and cannot represent associated alpha correctly. Pixels that are emissive and transparent at the same time will not show (for example when rendering fire).

If you composite an image (or a solid color) behind it you'll see the correct results though.

enter image description here

If you need to export the image with transparency use EXR, do not use PNGs, then just bring the EXR sequence and composite using alpha over.

$\endgroup$
  • $\begingroup$ realted: blender.stackexchange.com/questions/41574/… $\endgroup$ – cegaton Jul 14 '16 at 1:33
  • 3
    $\begingroup$ Cegaton I wish that I could upvote this more than once. Its one of Blender's age old mysteries. $\endgroup$ – 3pointedit Jul 22 '16 at 0:27
  • 3
    $\begingroup$ I second @3pointedit wish. I want to upvote this 10 times. And give you an award for that "the viewer is broken" gif. $\endgroup$ – Gez Feb 24 at 16:33
3
$\begingroup$

You can separate RGBA, then recombine with the RGB parts contributing to the A instead of the original image. Use a mix color node or something to combine the RGB channels then feed into the alpha of the combine RGBA node. Use a material index mask to splice in anything you want to keep pure(ie the metal lightsaber part of this image)

https://i.gyazo.com/f1c0b0fd6ca821aeda8efe26ca5e8181.png

$\endgroup$
  • $\begingroup$ Since it was not explained clearly, that "Lighten" node is actually called a "Mix" node. $\endgroup$ – Logic1 Jul 4 '18 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.