0
$\begingroup$

Okay, I did look up other questions and actually I found that I need to use Bevel modifier for this, but due to a way of how my mesh is made, it creates the shape which I don't want, what can I do to remove those "damaged look" parts from my mesh? As you can see below, adding Bevel modifier smooths it out how I wanted it to be smoothed out, but it also smooths out in between the vertices and adds (random?) dents, giving this weird look.

My mesh and problem that occurs:

enter image description here

enter image description here

Any ideas? All vertices (I checked thrice just to make sure and really couldn't find any single one out of place) seem to be in their places (on x plane, all vertices have same x, on y plane they also have same y and so forth...)

$\endgroup$
  • 1
    $\begingroup$ Have you tried the 'angle" option of the bevel modifier ? $\endgroup$ – lemon Jul 13 '16 at 17:22
  • $\begingroup$ Thank you, it worked! I still had to change few vertices after that but that was unrelated to initial problem, I guess I should look more before asking, anyway I started using blender only few days ago so I don't really know much. $\endgroup$ – Purple Ice Jul 13 '16 at 17:32
  • 1
    $\begingroup$ Don't hesitate to ask... If someone knows all is simple ! $\endgroup$ – lemon Jul 13 '16 at 17:35
2
$\begingroup$

the problem is that some of the faces are triangulated, resulting in the bevel modifier having a hard time in finding a desirable solution. looking at the model you have there, you could automatically clean up the geometry using a decimate modifier BEFORE the bevel, set its mode to planar, and then, as lemon suggested, use the angle method in the bevel. See those two screenshots here:

input geometry issue when triangles are used after plugging a decimate modifier inbetween

$\endgroup$
  • 1
    $\begingroup$ I already solved it (lemon thought that it's better to just comment under my question instead of answering it), but thank you for further explanation. Also it was lemon who suggested that, I asked question, lol. Anyway, when should I use decimate? Is it what I need when I want to export my model into Unity(any game engine) and want to reduce vertice/triangle count? $\endgroup$ – Purple Ice Jul 13 '16 at 18:12
  • $\begingroup$ decimate can be used to reduce the vertex and face count of a mesh using a few automated algorithms. It can be helpful in many situations, I use it for instance to clean up 3D Text geometry automatically, which tends to be a bit dirty at times. For exporting I'd say it depends: most game engines don't like n-gons at all, many triangulate the mesh automatically on import. So you'd decimate in Blender, they add the same stuff back on import. However, if Un-Subdivide or Collapse mode works for your situation, that would really reduce the poly count. $\endgroup$ – aliasguru Jul 13 '16 at 18:50
  • $\begingroup$ Well for this example, it seems that I could decimate and yes I know, Unity uses only triangles, so Unity itself would triangulate (I am not sure, maybe blender does that when exporting to .obj) but would do it better since some vertices which aren't needed (middle ones as you could notice), are removed forever, so in the end it's still worth it? My finger won't fall off from adding one more modifier :P $\endgroup$ – Purple Ice Jul 13 '16 at 18:55
  • $\begingroup$ it's definitely worth trying, but be aware that the modifier changes the geometry, so your textures (or better said UV Layouts) might be affected. With this example you might be right, it could reduce the poly count indeed. $\endgroup$ – aliasguru Jul 13 '16 at 18:59
  • $\begingroup$ Thank you, also I didn't try texturing at all, but I'll keep this in mind. $\endgroup$ – Purple Ice Jul 13 '16 at 20:20
1
$\begingroup$

A complement to aliasguru's answer, because the behavior of bevel rely also on the inner geometry of the mesh, not only its aspect in object mode. And this is important to understand, because, if the geometry is really not the good one, at some point, no bevel option can correct it.

If you redo the geometry like this, with quads (4 vertices faces) only, there is no bevel problem (and by the way, concerning your other recent question, you have a lower polycount).

enter image description here

But if you introduce triangles in it : enter image description here

Blender is a quad tool, and this matters a lot.

Another example with subsurf modifier instead of bevel, with quads on the left and tris on the right :

enter image description here

So if you want to use the angle limit, this may be mainly because we don't want to add too much (or unnecessary) geometry to the model.

Here, bevel with limit 'none' on the left and with limit set to 'angle' on the right : enter image description here

$\endgroup$
  • $\begingroup$ Okay, that makes sense, though I did a whole different process as I found out that I can bevel only selected vertices, so I chose only corners and ctrl+B'd them, though decimate still did a pretty good job with removing those inbetween vertices. Also I did that corner from a cube (deleted inner corner vertice that wasn't needed), so I think that's why it was so messy. $\endgroup$ – Purple Ice Jul 14 '16 at 6:57
  • $\begingroup$ Okay, beveling with ctrl+B is good too. But two things : this is not removable (the modifier is removable) and so if there is a mistake somewhere, all may be to be reworked again. Also you can use weight or vertex group options of the bevel modifier to specify the edges you want to be beveled (even if there is some limitations to do that as this is at vertex level and not at edge level). $\endgroup$ – lemon Jul 14 '16 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.