2
$\begingroup$

Blender novice here. I'm trying to make some models to use in the Unity3D engine.

I modeled a high poly tube and the low poly counterpart. Now I'd like to bake the normal map from the HP to the LP in order to make it look better. Unfortunately the normal map is horrible, it seems that I somehow tried to bake from the lowpoly to the lowpoly.

I followed this process:

  1. Make the high poly
  2. Make the low poly
  3. Unwrap the low poly
  4. Switch to Cycles renderer and assign a 1024x1024 image
  5. Switch to Normals under Bake
  6. Bake
  7. ..
  8. no profit?

This is my high poly and perfectly smooth tube and its counterpart, the low poly and perfectly jagged tube:

High poly and low poly

This is the result from the bake with "Selected to active":

With normal map

I may have been missing something during the process. What could be?

$\endgroup$
  • 3
    $\begingroup$ Welcome to the site! One of things to check is whether shading was set to Smooth for lowpoly. Other than that, were objects placed in the same place ? $\endgroup$ – Mr Zak Jul 12 '16 at 13:03
  • 1
    $\begingroup$ To me, there will be no result in this bake anyway, as the HP is smooth, so you will not obtain a significant normal map. But in the principle, as @MrZak said, the two object need to be at the same place (overlap) $\endgroup$ – lemon Jul 12 '16 at 14:49
  • 1
    $\begingroup$ watch out the order in witch you select your two objects for baking, first high poly, then low poly. This is what is meant by selected to active so that I guess you could bake small other objects as part of your normal map (like stones on the ground) because every object you select is "selected" but the last one in case you noticed has a slightly different selection color and it means 'active'. very usefull $\endgroup$ – Yvain Jul 12 '16 at 14:55
  • $\begingroup$ @MrZak yes, the two objects are in the same place. It turned out that I missed the Smooth option! Now everything is nice. Thank you very much! $\endgroup$ – D. Joe Jul 12 '16 at 16:47
1
$\begingroup$

Firstly, make sure everything is smooth shaded. Then see to it that all normals are facing in the right direction. Or you can simply go to Edit Mode and press Shift+N and normals will align to the face direction. If this does not help you, check your UV and make sure there are no overlapping UVs.

$\endgroup$
-1
$\begingroup$

you need to apply smooth shading to the low poly object first then bake it again

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.