Something happened when editing a Blender scene that caused me to lose the whole texture properties window and most of the materials window as well. They all appear as normal when starting a new file, but for this file they seem to be permanently gone.

This is what the window looks like now:

enter image description here

up vote 7 down vote accepted

It seems you changed the rendering engine to Cycles accidentally. In the Info window (aka the main menu), click the drop-down list which reads “Cycles Render” and change it to “Blender Render” (or “Blender Game” if you are using the Blender game engine).

Screenshot

When using the Cycles render engine, the textures tab will only show if you have a texture added to your material.

If there's no texture properties, then you can enable it by assigning a texture of any kind to the color input of your shader.

  1. Click the dot for the Color Input of your shader
  2. Select a texture of any kind
  3. The texture properties will now be shown

Assigning A Texture To The Color Channel Cycle's Texture Panel

There is also a bug that causes the texture tab to disappear, regardless of whether or not you have a texture applied. You must restart blender to have it reappear.

  • 1
    This is actually extremely important to note. Many will think it's their node setups or render engine choice. – lakerice Aug 11 '17 at 22:16

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.