2
$\begingroup$

I am trying to make a very simple diagram. I have these arrow-like objects that are inside of a transparent box. The arrows have this "shadow" on them, making them look dark. This effect looks fine on everything but the yellow arrows. I have removed all shadow effects, messed with lighting a little, and nothing changes. I am thinking it is texture related. I brought one arrow outside of the box, and it is still there. I have included a couple screenshots of the image and my settings.

I am extremely new to blender, and I am trying to keep this project relatively simple, so I would appreciate the simplest possible fix.

enter image description here

$\endgroup$
  • $\begingroup$ It could help if you add to your question screenshot of one of those arrows while in Edit mode. Things to consider iin this case are mesh geometry, position of the lamp sources and render engine options regarding to shadows (in case of BI you could turn off Raytracing). $\endgroup$ – Mr Zak Jul 11 '16 at 20:11
  • $\begingroup$ I added a picture of where the lamp is, and a close up of the arrows in edit mode, I hope that helps. Here are some things I just tried: 1) If I turn off the shadow setting on the lamp, it is still there on the arrows. 2) I just tried moving the lamp around, and it does change the positioning of the shadows, but it looks even weirder with the lamp in other places. $\endgroup$ – Physika Jul 11 '16 at 20:38
  • $\begingroup$ Hi... As I understand the issue, this is pretty easy to solve in cycles (turn off shadows for lamp; turn off shadows for the object). Is that an option? $\endgroup$ – rcgauer Jul 11 '16 at 21:09
  • $\begingroup$ Awesome, it does look better in cycles render. However, the method I used to make the box transparent (I followed a tutorial) only works if I am in blender render, so I guess I'll have to find another way to make it transparent. $\endgroup$ – Physika Jul 11 '16 at 21:26
  • $\begingroup$ Make your box out of a transparent or glass BSDF to begin.... depending upon lighting and your desires, they may well get you there. $\endgroup$ – rcgauer Jul 11 '16 at 21:32
2
$\begingroup$

It's hard to tell from the images alone what you mean, there may actually be two different issues at play here.

As mentioned by Mr Zak you could easily make your arrows shadeless either by

  1. Increasing Emission - This will make the object as if it were emitting light, it will partly retain shadows and glossy reflections (with the right render settings you can even actually maker them glow if you render with Blender Internal)
  2. Turning on the option Shadeless under the Properties Window > Material Options > Shading - This Will make your object flat colored, as if it were bi-dimensional, no shadows, no glossiness, or shine, and no light emission (basically doesn't react to lighting)

There is another issue at play here, that may be slightly messed up normals which will yield weird or unexpected shading. Use an edge split modifier on all your objects to make shading as expected.

Have in mind that switching to Blender Cycles may not be a full lasting solution on it's own, it will require setting up materials and scene differently from scratch since they are two completely separate and independent render engines, and Blender Internal materials are incompatible with Cycles and vice-versa

Shadeless Arrows

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.