When i made a new action called reload , it all looks fine and dandy ... and then i move the green line frame thing andmove it one bit THIS happens ... I swear nothing works ... Before moving green line

  • $\begingroup$ Nope.(everything is X-ray ) $\endgroup$ – Knuckles209cp Dec 24 '13 at 5:54
  • $\begingroup$ so you want the .blend file? , oh by the way i have animated before but this never happened , it only happens when i make a new action $\endgroup$ – Knuckles209cp Dec 24 '13 at 5:57
  • $\begingroup$ yup , if i understand what you said right , everything works absolutly perfect , i have a youtube video of a previous animation i made and nothing was wrong with that , youtube.com/watch?v=GAJF89jAmTc , different arms same rig - i think it has everything to do with the action $\endgroup$ – Knuckles209cp Dec 24 '13 at 6:01
  • $\begingroup$ Yes, please upload some .blend file with this problem. $\endgroup$ – Adhi Dec 24 '13 at 6:22
  • $\begingroup$ ok where should i upload it $\endgroup$ – Knuckles209cp Dec 24 '13 at 6:28

The most frequent cause of this problem, in my experience, is multiple Armature modifier on the object. With that setup, the mesh deformed by the first Armature modifier gets further deformed by subsequent modifiers, which results in broken deformation.


Also check that the bones are keyframed using plain Location / Rotation / Scale keying set. Keyframing with Visual Loc/Rot/Scale can ruin certain constrained bone setup. (Just for more complete information. This is unlikely in your rig's case, being not constrained at all.)

EDIT: I've seen the file, and found the rig animatable as expected.


But I notice the hand object is scaled way down to fit the armature. That could be a problem, because it'd ruin the animation if the object's scale is somehow reset or keyframed to a different value. Maybe you've done something inadvertent when keyframing this particular action, that triggers the object scale's change. I suggest to Apply Ctrl-A > Scale the object and redo the animation data.

|improve this answer|||||
  • $\begingroup$ how do i check how many modifiers i have on my armature? $\endgroup$ – Knuckles209cp Dec 24 '13 at 7:05
  • $\begingroup$ Check the mesh, not the armature. Actually what's contained in your .blend itself still doesn't provide any clue, so this answer relies on guesswork. $\endgroup$ – Adhi Dec 24 '13 at 7:06
  • $\begingroup$ ok what i could do is give you the whole file if you want , see if that works since you know whole lot more than me :) Oh and thanks for the help i really appreciate it ! $\endgroup$ – Knuckles209cp Dec 24 '13 at 7:08
  • $\begingroup$ Are . you . kidding . ME . I think i just solved the problem , i set the keyframe settings to LocRot AND scale , before , i only had it to LocRot $\endgroup$ – Knuckles209cp Dec 24 '13 at 7:10
  • $\begingroup$ Well, that's unexpected. Glad it's solved :) $\endgroup$ – Adhi Dec 24 '13 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.