-2
$\begingroup$

I want to fix the black area in the mirror. I used Glossy BSDF to make it and I'm using cycle render. And I want to know how to hide the cyan planes from the scene and keep their effect.

The black area...

$\endgroup$
  • $\begingroup$ blender.stackexchange.com/questions/36503/… $\endgroup$ – user1853 Jul 10 '16 at 17:37
  • $\begingroup$ If it is mirror which is the question about in the left corner inside of cupboard then check modifiers for it (particulalry, Subsurf) and show the modifiers' stack. $\endgroup$ – Mr Zak Jul 10 '16 at 17:53
  • $\begingroup$ It was without modifiers but I add subsurf and the black area has rounded it $\endgroup$ – Ahmed Nezar Jul 10 '16 at 18:01
  • $\begingroup$ So the black area appeared after you added Subsurf ? $\endgroup$ – Mr Zak Jul 10 '16 at 19:40
2
$\begingroup$

Starting with a scene like this:

enter image description here

Select the emitter objects and disable the ray visibility for camera and glossy.

enter image description here

As to why the round shape on your mirror.

If your mirror is rectangular you'll be gaining anything by adding a subsurf modifier to it. Subsurf modifier's default behavior is to round out geometry by interpolation:

enter image description here

enter image description here

If you must have the subsurf modifier change the interpolation from Catmull-Clark to Simple.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks it worked, But the mirror $\endgroup$ – Ahmed Nezar Jul 10 '16 at 17:51
  • 1
    $\begingroup$ Please ask one question at the time. $\endgroup$ – user1853 Jul 10 '16 at 18:22
  • $\begingroup$ related: blender.stackexchange.com/questions/19146/… $\endgroup$ – user1853 Jul 10 '16 at 22:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.