2
$\begingroup$

How can I get rid of that weird shadows for edges in edit mode with viewport Ambient Occlusion (Properties Panel > Shading) enabled?

AO disabled

enter image description here

AO enabled

enter image description here

$\endgroup$
3
  • $\begingroup$ Has the object you are working on a subdivision surface modifier? $\endgroup$ – Carlo Jul 10 '16 at 14:26
  • $\begingroup$ @Carlo Yes, It has a subdivision surface modifier, but I don't understand why do you ask? $\endgroup$ – Monkok Jul 10 '16 at 15:06
  • $\begingroup$ I asked for having more info about of why "the lines" are generated only upon certain edges. $\endgroup$ – Carlo Jul 10 '16 at 15:19
3
$\begingroup$

Disable Faces Overlay

Because the way viewport's AO is currently built (2.77), everything is drawn in the 3D viewport is taken into account.

enter image description here

What you see is probably the projection of adjusted faces that comes from the unmodified mesh. Basically, as in edit mode you see two version of the same geometry (even with "Adjust cage ..." enabled, it's only projected upon the modified mesh), you get AO from both meshes.

enter image description here

If it is suitable for your workflow, one possible workaround could be to disable the Faces option in the Overlay section of the Mesh Display panel in the Property of the viewport.

enter image description here

$\endgroup$
1
  • $\begingroup$ Your solution is almost perfect, thank you! The only thing that now I miss is highlighting of selected faces =P $\endgroup$ – Monkok Jul 10 '16 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.