3
$\begingroup$

I can't subdivide the front face in a model. I want to put more materials on the model, I used a Boolean modifier, and caused triangle faces. I don't know if that makes any difference but I need to subdivide it so badly it's getting on my nerves.

Thank you

Here's a picture of the model enter image description here

$\endgroup$
  • 1
    $\begingroup$ it's probably because it's an ngon,try subdividing manually with the knife tool $\endgroup$ – user2816 Jul 9 '16 at 18:14
  • 3
    $\begingroup$ Big ugly n-gon... Delete it, select then the vertices on the edge and do grid fill to go create quads. $\endgroup$ – cegaton Jul 9 '16 at 18:30
  • $\begingroup$ Do you mean the whole object or the face $\endgroup$ – hamzah hajmousa Jul 9 '16 at 19:22
  • $\begingroup$ Related - blender.stackexchange.com/questions/53130/…. To be able to subdivide face there, you need another kind of topology in that region. It's up to you what method to use for that - either deleting face and recreating with GridFill or splitting existing face with Edge tools. $\endgroup$ – Mr Zak Jul 9 '16 at 20:05
  • 1
    $\begingroup$ Boolean modifier does not ensure a "good" inner geometry. In particular when the initial mesh is already dense (as yours seems to be). To me this modifier is often a false good idea when this kind of consequences are not known in advance. As @cegaton said, the best is to delete the face and try a grid fill. $\endgroup$ – lemon Jul 9 '16 at 22:21
6
$\begingroup$

Boolean operations are a convenient way to transform geometry, but they can leave behind other problems. In this case you've generated a big and ugly n-gon (a polygon with more than 4 vertices). Ngons are notorious for deforming in unpredictable or undesirable ways. In general is preferable to work with quads.

enter image description here

Start by getting rid of the ngon

enter image description here

select the edge loop by pressing Alt while slecting an edge.

enter image description here

Press the space bar and type grid fill (or press CtrlF and select grid fill)

enter image description here

And play with the grid fill settings until you get something that does look like a grid.

enter image description here

$\endgroup$
0
$\begingroup$

Looks like an N-Gon.

To check if a mesh has N-gons do the following.

  • In edit mode go to face selection
  • Choose select from your 3d menu bar
  • Select All by trait
  • Select faces by sides
  • In the tool panel set the number of sides to 4(its at the bottom you may have to scroll to see it)
  • set the type to greater than

This will show you any face that has mort then 4 sides

Hope it helps

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.