1
$\begingroup$

enter image description hereenter image description hereSome parts not getting texture

I'm going through some online tutorials and am having trouble understanding how to fix my issue. From the screenshot, you can see that when I select a face on my model, the corresponding section of my texture is highlighted. However, the color isn't applied. If I select the face immediately above it, the expected section on the texture shows as well and I'm not able to determine how these are different.

If it helps, I'm sharing my files (in particular, 'Dave.8.blend') in the hopes someone can point me in the right direction.

https://www.dropbox.com/sh/s6uk9cbm7l75x0a/AAArWNxiA4itkHO3uCYKg9Vpa?dl=0

Here's what I've tried so far: - There is discussion of the 'normals' being wrong, but using [ctrl]-[n] didn't seem to make any difference. - I've tried changing my light source (as a noob, that seemed to be a possibility) - lots of online searching, but nothing clicked for me.

EDITS Added Normals screenshot, Added flipped normal screenshot

$\endgroup$
  • $\begingroup$ some of your normals are inverted, but not all (verified with your blend file). Try to play with ctrl+N or shift+ctrl+N, selecting the good faces. The easiest way to identify these faces is to activate "backface culling" in the information panel (shading section) $\endgroup$ – lemon Jul 8 '16 at 17:27
  • $\begingroup$ In fact, you have non manifold geometry and this is due to double vertices (but not only). So select all in edit mode, then remove doubles. But this does not repair all... curious $\endgroup$ – lemon Jul 8 '16 at 17:40
  • $\begingroup$ I used another tip to show the normals, but they all seem pointed in the right direction.... changing the Backface culling flag had no visible effect. Other thoughts? $\endgroup$ – not-bob Jul 9 '16 at 1:16
1
$\begingroup$

In the dave.8.blend file you definitely have a number of faces that have the normals backwards. You need to select all the faces that look black, then flip the normal direction on them.

enter image description here

For reference: Limit Selection to Visible button

enter image description here

$\endgroup$
  • $\begingroup$ When I do that, it starts to look hollow (see new screenshot). For giggles, let me see if I can get a newer version (up from 2.69...) $\endgroup$ – not-bob Jul 9 '16 at 2:45
  • $\begingroup$ Try toggling the Limit Selection to Visible button to the right of the Face Select icon in the bottom toolbar. See image in bottom of my answer. $\endgroup$ – Todd McIntosh Jul 9 '16 at 2:49
  • $\begingroup$ Not any better. The only change is to show a block in the center of each face $\endgroup$ – not-bob Jul 9 '16 at 2:56
  • 1
    $\begingroup$ It was my version...... 2.69 has this issue but 2.77 does not. Holy Cow! $\endgroup$ – not-bob Jul 9 '16 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.