1
$\begingroup$

As I started to add materials (glossy) to my objects, at one point in that process I realized I couldn't see one of my objects.

It was still "there" because all that remained was a grey dot (which turned orange when the shape was selected) presumably at its center of mass. I assume this is the 3D manipulator?

When i clicked it, it let me move this invisible object and scale it etc, but I couldn't see it in object mode, edit mode, rendered, wireframe, sculpting. You get the idea...

I need this fixed to continue with my model. Also, I'm new to blender.

Thanks

Pics: (I named the invisible object invisible)

The grey dot

It still recognizes it as an object?

$\endgroup$
  • $\begingroup$ It might be an object with a single vertex that you accidentally created. Why don't you just delete it, or back-step (Ctrl-Z) to get back to where it wasn't like that? . $\endgroup$ – Anthony Forwood Jul 7 '16 at 0:06
  • $\begingroup$ @AnthonyForwood I dont think I accidentally created it because I renamed it from previously something like "cylinder 001". However at the top of my screen it tells me I have 0 vertices etc so maybe I might have deleted it?? But if i deleted it why would blender still count it as an object. $\endgroup$ – lest23 Jul 7 '16 at 0:21
  • 1
    $\begingroup$ Blender still counts an object with zero vertices an object when you delete all the vertices in edit mode. Upon return to object mode it still thinks it is an object because you didn't "delete" it. $\endgroup$ – Unnamed Sentient Being Jul 7 '16 at 0:59
  • $\begingroup$ Unfortunately you cropped the picture on your question leaving out the clues that would help us determine what is wrong. Are you in edit or object mode? is the visibility (eye) icon disabled?. Other thing that might have happened is that the geometry is hidden in edit mode. Try Alt H $\endgroup$ – user1853 Jul 7 '16 at 1:11
  • $\begingroup$ @cegaton wouldn't it be impossible for him to select the object if he enabled restrict viewport visiblity? $\endgroup$ – Unnamed Sentient Being Jul 7 '16 at 1:19
0
$\begingroup$

To make this an official answer:

Why is it there?


Blender still counts an object with zero vertices an object when you delete all the vertices in edit mode. Upon return to object mode it still thinks it is an object because you didn't "delete" it.

How do I fix it?

A. CTRL+Z
B. Start over, hit X then D to delete your zero vertex object

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.