2
$\begingroup$

July 5th lots of fireworks vids. Using VSE I would like to overlay some of them on each other. So convert all the black in the scene to transparent then render it out and bring the .png files back in and over lap the fireworks on top of each other... Using nodes in the Compositor. I have seen some tutorials added the Movie and Composite output setup a colorramp off the clip to the AlphaOver node Loc; with Image1 full transparent and in image two the movie clip image.
The viewer shows the fireworks on transparent background. output .png ; for 24 frames; click animate and all the png rendered with black where the viewer shows transparent.. no alpha channel in rendered output.

$\endgroup$
  • 1
    $\begingroup$ Can you add an image of your node setup and render settings? $\endgroup$ – cegaton Jul 6 '16 at 1:18
  • $\begingroup$ You need to choose an output file format which supports transparency. Go with an image Sequence of OpenEXR or PNG first. $\endgroup$ – Samoth Jul 6 '16 at 6:28
  • $\begingroup$ I couldn't find an image upload button... I'll attempt another location. Tried.png, .next. and Tara always selecting RGBA. $\endgroup$ – NonAltoCG Jul 7 '16 at 3:31
  • $\begingroup$ tried .png, targa, targa ras and Open Exr... I took a screen shot put it link $\endgroup$ – NonAltoCG Jul 7 '16 at 11:47
1
$\begingroup$

I'm a bit confused here, did you want to composite the images using the VSE or the compositor? No need to do it twice, either section is capable of doing what you're asking.

If the background is completely black you don't need to change the alpha. A common way of compositing images with dark backgrounds is to mix them via luma keying. You can try to add alpha channels, but an easier way for this application would be to just add the clips.

In the VSE this can be done by selecting the clips above your base clip and setting the blend mode to add instead of cross.

mix mode setting photo

In the node editor add a color->mix node and set the mode to add. Hope that helps.

$\endgroup$
  • $\begingroup$ Thanks Zac, doing it with ADD in the strip editor is much better than what I was attempting. .. Still unsure why the Viewer shows the Transparency and the rendered .png files do not have the transparency. $\endgroup$ – NonAltoCG Jul 7 '16 at 17:24
  • 1
    $\begingroup$ Add isn't an alpha over. In the compositor, do a series of math nodes to max(RGB). Use result to "Set Alpha". Save to half EXR. Then do a proper alpha over. Remember: Alpha must have a knockout / occlusion component. $\endgroup$ – troy_s Oct 5 '16 at 21:12
  • $\begingroup$ I realize add isn't alpha over, and that alpha is more proper, but note my specific qualification 'for this application', and simpler. $\endgroup$ – Zac Oct 7 '16 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.