2
$\begingroup$

Im working on a new Anime/Toon Material for all of my characters for a short film type thing. The main issue is that when I render I get these squares in the render that I don't see on the preview, or in cycles Problem. I want it too look like this and this is what the render preview look like Intended Look

How do I fix this? here's the file http://www.pasteall.org/blend/42587

The problem seems to be withe the solidify modifier but i need the "line" Effect and don't want to use blender freestyle as I can't get a good preview of the look without constant rendering, witch really messes with my workflow.

$\endgroup$
1
$\begingroup$

The reason for discrepancy are different settings for preview and render of the Multires modifier.

From manual:

Preview
Set the level of subdivisions to show in the 3D View.

Sculpt
Set the number of subdivisions to use in Sculpt Mode.

Render
Set the number of subdivisions to show when rendering.

In your file, Render option is set to 1, and thus it uses the first level of subdivision when rendering image.

screenshot of different multires settings

On this level mesh becomes more bumpy and with rough sides, which reflect the light you see on the rendered image.
It is not visible in 3D Viewport because Preview is set to 2, which makes mesh smoother only for previewing it in the viewport.

See related answers:

Object appears smoothed after rendering but not in viewport - specific case with Multires modifier.

Cycles viewport render different than f12 render? - general things to consider when preview and render results differ.

$\endgroup$
  • $\begingroup$ It looks Better, but im still getting small squares under the arm's. Looks near the left armpit withe the light set to sun or point. $\endgroup$ – Steven Jul 12 '16 at 3:35
  • $\begingroup$ @Steven I didn't see any real difference between rendered image and preview render except for normal differences in antialiasing which is what will differ in any way. You could look at technical differences between them $\endgroup$ – Mr Zak Jul 12 '16 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.