6
$\begingroup$

I have a nice procedural dirt texture made up for a sphere, but when I play the game with an object that utilizes the texture, it will only show the color of the defuse and completely ignore any textures.

Even when I switch back to the Blender Render mode, the renders will not display the texture. Hopefully this image will give you some context.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Not 100% sure but it may be that nodes aren't supported in the BGE (could be a performance choice). You can use the nodes material you have to bake to an image texture that can be used within the BGE $\endgroup$ – sambler Dec 22 '13 at 7:45
  • 2
    $\begingroup$ BGE doesn't support generated textures. Try baking the textures to an image. $\endgroup$ – Nero1024 Dec 23 '13 at 11:24
  • 2
    $\begingroup$ If you post that as an answer I could mark it as the answer. That way people who stumble upon this will see it as the answer. $\endgroup$ – user3015600 Dec 23 '13 at 18:11
5
$\begingroup$

If you are using GLSL shading mode, and the Nodes option is checked in the render tab of the properties window (by default it is); then the BGE supports material nodes. However procedural textures, and generated texture coordinates are not supported.
shading options for the BGE


To be able to use your procedural material, you will have to bake it, then use the resulting image in a new material in the game.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.