4
$\begingroup$

I'm trying to work with an image in the VSE that is larger than the rendered screen and the VSE always cuts them off. So either they are stretched to fit the screen or (when using "image offset") they are cut and cropped. in the specific example I want to use a map over which I want to pan and zoom in, but not use the default camera-setup because I don't do anything in it anyway, just use VSE and strip modifiers. So how do I get blender to use the WHOLE image instead of just a cropped 1920x1080 selection of blank ocean?

$\endgroup$
  • 1
    $\begingroup$ maybe this can help you: blender.stackexchange.com/questions/42094/… $\endgroup$ – cegaton Jul 1 '16 at 13:50
  • $\begingroup$ Thanks, not what I was looking for at all, since this is about quality and zooming in, not panning. As I said: blender just pretends as if the rest of the image doesn't exist and makes the image STOP at the viewed/zoomed section. The only way I can introduce an image larger than the rendered plane is to downscale it in another programm first, and then, of course, Quality is lost. $\endgroup$ – Keen Gaze Jul 2 '16 at 13:13
2
$\begingroup$

Currently not possible to do that without some image quality loss.

If this is allowed then do the following:

Option 1

  1. Add your image as a strip.
  2. With the strip selected add Effect Strip -> Transform.
  3. In Transform strip properties choose Bilinear for interpolation (or try with the other options to your liking).
  4. Now scale the image. Assuming you are using 1920x1080 for render dimensions - type the expression (with numbers) in Scale - for X - [your_image_width]/1920; for Y - [your_image_height]/1080. This will set upscale factors for the image which will restore its original dimensions and also here the image quality loss occurs.
  5. Now you can pan or zoom in the Transform strip using Position and Scale respectively. For Scale from now on always multiply X and Y with the same scale factor. For example if you want to scale the image down in half multiply the values by 0.5. If you want to scale up twice - multiply both values by 2.

Option 2

You can always import the image in the 3D view as plane. For that you can use the plug-in

Import -> Images as Planes (if not there, enable it in User Preferences)

  1. Make the camera orthographic and orient it so it looks directly towards the image plane.
  2. Set the 3D view to Textured. Scale and move the plane from Camera view to your liking.
  3. In VSEditor add the Scene where the image is as a strip. In Sequencer Image View properties choose Scene Preview/Render to be Textured.
  4. You can open 3D View window and animate the scale and position of the plane. To see the updated plane, Refresh the sequencer or change frames in the timeline.

Option 2 has better image quality than Option 1 but requires you to work in the 3D space.

$\endgroup$
1
$\begingroup$

Add an image in the MCE (Movie Clip Editor or Tracker tool). Apply at least one tracker ctrl-click on image. then turn on the 2D stabiliser and begin applying changes to scale, rotation or offset/transform.

In the VSE add a Movie "Clip" to the timeline, choose the same clip that you just modified. In its properties N-Key, turn on Stabilisation. To see the changes you make in the MCE you must click the "Refresh Sequencer" button.

Movie clip scale in VSE

$\endgroup$
1
$\begingroup$

I made this in the VSE using the updated VSE_Transform_Tools addon and this large NASA Image.

enter image description here

Use the keyboard shortcut Alt+S to set the image to it's original scale. See the addon's readme page for more info.

$\endgroup$
  • $\begingroup$ Nice add-on. Alt+S does exactly what I described in Option 1 of my answer. Unfortunately the image quality is not very good with this method because the image is once resized automatically and once again using the Transform effect. $\endgroup$ – Rumen Belev Apr 15 '18 at 20:09
  • $\begingroup$ Indeed. I can't see a way to get around this loss of quality without going out to the 3D window or using the compositor. $\endgroup$ – doakey3 Apr 15 '18 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.