1
$\begingroup$

I have an image which has been added by Images as a plane. Now if I create a cube above the plane I want the shadow of the cube to be visible on the texture. How to do this?

Update: this is my plane in nodes view now:

enter image description here

$\endgroup$
  • 2
    $\begingroup$ In cycles all of the objects cast and receive shadows by default, there is nothing to set up. $\endgroup$ – cegaton Jul 1 '16 at 15:12
1
$\begingroup$

There are two solutions. Option 1 is easier and better.

Option 1 (Diffuse)

When importing the the image, make sure that you have Diffuse selected under Material Settings on the left side.

enter image description here

Option 2 (Emission)

I have searched far and wide for a solution to test for a shadow so that one can use the Emission setting with some extra nodes, but eventually concluded that it cannot be done. The final word came from gandalf3's answer here. You can, however, do a workaround through RenderLayers, if you so desire.

Final result:

enter image description here

Nodes:

enter image description here

What I have setup are two RenderLayers. One with the cube and image (Scene), and one with a plane with identical dimensions to the image with a plain Diffuse BSDF material (Shadow). I also enabled Transparent under Properties panel > Render tab > Film drop down.

This is the .blend file:

$\endgroup$
  • $\begingroup$ for Option 1. If I go to Material tab (image is already imported as plane). I go to "Surface" and see: Surface=emission, Color:Image Texture, Strength: 1. but if I change Surface=emission to Diffuse BSDF, my text object doesn't drop any shadow. any ideas? $\endgroup$ – juFo Jul 1 '16 at 14:18
  • $\begingroup$ @juFo There could still be a light path node in your node tree. I will say that the option that I have a picture of is visible in the file browser only when you are selecting which image to import. If this doesn't help, please consider posting screenshots. Also, if this or my answer helped, please consider accepting it. $\endgroup$ – Shady Puck Jul 1 '16 at 14:23
  • $\begingroup$ see my updated screenshot. $\endgroup$ – juFo Jul 1 '16 at 14:40
  • $\begingroup$ @juFo on its own, that node set up should receive a shadow. I can think of a couple other things that might be the cause. Can you upload your .blend file to Blend Exchange? Before you do upload it, you should go to File > External Data and check Automatically Pack Into .blend. $\endgroup$ – Shady Puck Jul 1 '16 at 14:43
  • $\begingroup$ I'm using images I can't share. I'll have a look at it on Monday (got to go to a meeting now). I'll try to have a look in between this weekend. $\endgroup$ – juFo Jul 1 '16 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.