0
$\begingroup$

What I'm trying to do is create a robotic hand. I created the mesh and added the bones for the fingers (following CG Cookies' tutorial on rigging fingers), but didn't add a bone for the "arm" part of the mesh.

I've tried adding the bone (the arm bone is named Bone.020), created a vertex group with the same name, then weight painted the part it should move, but that didn't work. I have tried parenting the finger bones to the arm bone, but that didn't work. I don't know what else to do. Any help is greatly appreciated.

Object Data panel View of the Object Data panel

Bone panel View of the Bone panel

Bone Constraints panel View of the Bone Constraints panel

Fingers are working properly Showing the fingers are working properly

Rotating the arm does nothing The problem - Rotating the arm doesn't pivot where the "elbow" would be

Example of weight paint that works with thumb Example of weight paint that works with thumb

The weight paint area for the arm The weight paint area for the arm and palm

Armature modifier Armature modifier in the modifiers panel

$\endgroup$
  • $\begingroup$ I dont really understand the problem you are showing here. Bones need to rotate at their heads. So you probably need to rotate each bone from their head or complete with intermediate bones (between lower arm and finger) and assign weights to the appropriate parts of the model. Or ? Is there something else you show us in your question ? $\endgroup$ – lemon Jun 30 '16 at 17:47
  • $\begingroup$ You should upload your .blend file, to understand the problem $\endgroup$ – josh sanfelici Jun 30 '16 at 18:48
  • $\begingroup$ @joshsanfelici the .blend file is available. $\endgroup$ – Chris Jun 30 '16 at 20:50
1
$\begingroup$

What is going on here is strange, and I can't really determine what is going on. For whatever reason, no matter what I do, The hand does not follow that particular bone.

I just wound up remaking the bone, that seemed to get around whatever strangeness was happening.

I didn't bother rebuilding the parenting of the bones for the sake of this screenshot.

enter image description here

$\endgroup$
  • $\begingroup$ Can you send that to me? $\endgroup$ – Chris Jun 30 '16 at 23:41
  • $\begingroup$ I have that on a different computer. All I did was delete the bone and remake it. $\endgroup$ – Kirbinator Jul 1 '16 at 3:54
  • $\begingroup$ Thanks! I deleted and remade it and now it works. Thanks @Kirbinator $\endgroup$ – Chris Jul 1 '16 at 19:37
  • 1
    $\begingroup$ The problem was the bone didn't have Deform enabled. $\endgroup$ – Jaroslav Jerryno Novotny Jul 1 '16 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.