2
$\begingroup$

I have a map; a plane and a Solidify modifier. I have already applied an Image Texture to one side, but Blender is obviously applying the texture to both sides.

I want to add a different Image Texture to the other side of the plane, however. Is there a way to do this?

I have tried to add another one using the Geometry > Backfacing feature, but it did not work.

Map mesh and .blend file's material:

enter image description here

Viewport render of map mesh and Backfacing material (not working):

enter image description here

$\endgroup$
  • 5
    $\begingroup$ Related blender.stackexchange.com/questions/2082/… $\endgroup$ – Denis Jun 28 '16 at 18:31
  • $\begingroup$ The key piece of information you neglected to mention is that you are using a solidify modifier. $\endgroup$ – cegaton Jun 30 '16 at 0:14
  • $\begingroup$ The reason backfacing doesn't work is that you have a solidify modifier The solidify modifier will make it so all of the object has an front surface (the bakface would be the interior faces of the object. If you want your map to have thickness you need to apply the modifier and your plane will behave like a real object. Select the back faces and apply a new material to them: i.stack.imgur.com/kCySk.jpg $\endgroup$ – cegaton Jun 30 '16 at 0:15
3
$\begingroup$

There was only one image in the file, so I substituted a Diffuse BSDF for the second image. There are two options you have now.

Option 1

The reason that the Geometry > Backfacing did not appear to work was because that the Solidify modifier made it so that the map/diffuse went inside the map.

An exaggerated Solidify:

enter image description here

The solution if you want to keep the Solidify modifier goes like this. Apply all modifiers. Use the steps in Add different materials to different parts of a mesh? to apply the other image/diffuse to the non-map faces.

Option 2

Solution produced with Option 2 (low-res; 20 samples):

enter image description here

This is the better solution. Since the Solidify modifier does next to nothing, delete it, and the original node setup will work. The two Diffuse BSDF's outputs are crossed just because it needed to be inverted. I'm sure you understand.

enter image description here

The following .blend file produced the result at the top of Option 2.

$\endgroup$
  • 3
    $\begingroup$ Optionally you could also use the Backfacing output directly in a Color Mix Node to avoid having duplicate shaders $\endgroup$ – Duarte Farrajota Ramos Jun 28 '16 at 18:53
  • $\begingroup$ @DuarteFarrajotaRamos Agreed. Are duplicate shaders bad, though? $\endgroup$ – Shady Puck Jun 28 '16 at 18:54
  • 1
    $\begingroup$ Not bad per-se, just a slight optimization to make make the tree simpler, probably a few less seconds of render $\endgroup$ – Duarte Farrajota Ramos Jun 28 '16 at 19:33
  • $\begingroup$ @DuarteFarrajotaRamos I'll keep that in mind. $\endgroup$ – Shady Puck Jun 28 '16 at 19:34
  • $\begingroup$ I've added a new image, after i applied these nodes, but its not working as you can see, both sides of the plane, when rolled up are same texture. $\endgroup$ – TheRageMachine Jun 29 '16 at 17:52
0
$\begingroup$

I am able to use backfacing and solidify at the same time by checking the "Only Rim" option in the modifier.

only rim checkbox image

node setup

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.