1
$\begingroup$

I accidentally deleted a color ramp node that I was working all my colors on, and now when I cmd+z it doesn't do anything!

$\endgroup$
  • $\begingroup$ Undoing is done with Ctrl+Z menu. You can try access undo history Ctrl+Alt+Z and proceed from there (at least you'll know whether or not undoing is possible). $\endgroup$ – Mr Zak Jul 28 '16 at 11:08
  • 1
    $\begingroup$ Seems like undo is broken in the node editor completely. This should be reported as a bug. $\endgroup$ – Greg Zaal Jul 28 '16 at 11:52
  • $\begingroup$ I have the same issue. Yesterday Undo worked fine in node editor, but today it doesn't. The undo history shows all changes, but nothing happens when I select something. :( $\endgroup$ – Niclas Jan 4 '17 at 19:05
1
$\begingroup$
  1. Check User Preferences➜Editing➜ Undo➜ Step is not set to 0.

  2. Try undo from dropdown menu(assume tho you have tried this alraedy)

  3. Try restoring default key layout.

| improve this answer | |
$\endgroup$
0
$\begingroup$

The above solution should work, but it seems like a bug in the Undo history for the nodes editor.

Solution

  1. Switch to the 3d view
  2. Make a change, press CTRL+Z (it should work)
  3. Go back to the node editor, edit something, and CTRL+Z works again. Heureka!
| improve this answer | |
$\endgroup$
0
$\begingroup$

Hit ALT+SHIFT. You switched to a QWERTZ keyboard configuration (for example DE) by accident and are too far in the 3d zone to notice or think of it. Happens to the best of us.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy