2
$\begingroup$

enter image description hereIt is really hard to describe my problem accurately, but I try the best I can. I am using Blender to create meshes for Unreal Engine. However, this problem shows already in Blender. I donĀ“t know the terminology, So I go right ahead and describe shortly what is wrong about the picture attached. You can see a diagonal shadow cast after I turned on the smooth shading. That does not look very good (I am sorry, that I cannot describe it any better). You would really help me out if you could explain my mistake to me!

$\endgroup$
1
$\begingroup$

This is because you have Smooth shading enabled in your 3D Viewport > Toolshelf > Tools tab > Edit dropdown > Shading:. There is a way to fix this without going back to Flat shading.

Go to the Properties panel > Object Modifiers tab and add an Edge Split modifier. The default settings should be ok, but if they aren't, you can change the Split Angle:, which is defined as the max value at which an angle should be split.

The Edge Split modifier:

enter image description here

Comparison with a cylinder:

enter image description here

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.