2
$\begingroup$

When I apply an image texture to my material its fine. But when I Connect a Normal Map The objectis black in rendered view.

Without Normal Map enter image description here

With Normal Map enter image description here

Also how do you add a .blend file in your posts?

$\endgroup$
2
  • $\begingroup$ You can add your blend file using blend-exchange.giantcowfilms.com Please pack the textures in it (or at least the normal map). $\endgroup$
    – lemon
    Jun 26, 2016 at 16:38
  • $\begingroup$ You might want to try assigning a UV map to the normal map node. It's currently blank. Also make sure your normals are facing the correct way. In edit mode select all faces and press CTRL + N to recalculate all normals. $\endgroup$
    – Delagone
    May 12, 2017 at 11:57

3 Answers 3

4
$\begingroup$

Make sure you set your normal map textures color mode to non-color data.

You have to do this in the texture settings AND in the properties panel of the cycles material node graph panel

$\endgroup$
3
$\begingroup$

There is one other cause for Tangent Space normal maps turning black: if u are using microdisplacement (adaptive setting for subsurf modifier) normal map wont be able to calculate correctly, for this moment at least.

If you were to combine normal maps with "true" displacement, you can only choose between world and object space.

$\endgroup$
2
$\begingroup$

This is probably because your normals are not pointing in the right direction.

Tangent space normal maps rely on the surface normal in the approximation,so if the normals are not right the material won't work.

To recalculate your normal,select all faces in the mesh and press Ctrl+N,If this didn't work,you can check invert.

$\endgroup$
2
  • $\begingroup$ What do you mean by invert here? Is is just flipping Normals? If not, could you please explain how one can do it? $\endgroup$
    – Amir
    Mar 13, 2018 at 22:58
  • $\begingroup$ @Amir I think I meant use the Flip Direction operation in the shading panel. $\endgroup$
    – Omar Emara
    Mar 14, 2018 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.