1
$\begingroup$

[SOLVED] So I've learned how to use textures with transparency on Cycles render, and I'm trying to put many meshes with transparent textures in front of one another, so I could make a 3D scene with 2D images and textures, but i've discovered that rendering more than 5 or 6 transparent objects overlapping ends up making the a black ghost apear in between the layers... At first I thought that it was just light and I needed to separate the planes more, but that didn't work...

Here's a simple test I've done, it shows what is going on perfectly:

Not rendered

Rendered

So, anyone has any ideas of how to fix this? I've tried a couple different things but they all end like this...

Thanks in advance.

$\endgroup$
3
  • $\begingroup$ Have you tried increasing the number of transparency bounces in the render settings and see if it helps? $\endgroup$ – Duarte Farrajota Ramos Jun 25 '16 at 0:35
  • $\begingroup$ Make sure that the color of the transparent node is full white (by default when you create the node, it is not). This behaviour is usefull as you can for instance have a blue transparency. $\endgroup$ – lemon Jun 25 '16 at 7:50
  • $\begingroup$ @DuarteFarrajotaRamos YES that was it! Thanks for the help ^^ $\endgroup$ – Leonard Jun 26 '16 at 5:45