2
$\begingroup$

I'm encountering this strange problem where if I render out my image in Cycles with a gpu the normal map is messed up. Perhaps inverted.

It renders fine with the cpu (top image is rendered with CPU, bottom with GPU)

CPU GPU

Machine: Predator G9-591 CPU: i7-6700HQ GPU: GeForce GTX 970m OS: Windows 10 Version:Blender 2.77a

screenshot of the jean material node. enter image description here

$\endgroup$
6
  • 2
    $\begingroup$ You mean on the pants' pocket, right? $\endgroup$
    – Matt
    Jun 24, 2016 at 19:35
  • 2
    $\begingroup$ Could you post a screenshot of your nodes for that material/texture? $\endgroup$
    – Matt
    Jun 24, 2016 at 19:36
  • $\begingroup$ I wanna say this is a bug...? $\endgroup$ Jun 24, 2016 at 20:26
  • $\begingroup$ @someonewithpc a bug it can be (as is it just a rendering way difference), but hard to now if the pocket model (mesh, normals) cannot be checked.... $\endgroup$
    – lemon
    Jun 24, 2016 at 21:03
  • 2
    $\begingroup$ How many 16/32bit textures do you have? If you have more than 5 and your normal map is one of them, it won't load as Cycles in 2.77 is limited to 5 "float" textures (which is anything not 8bit). This is not the case in the nightly builds on buildbot, if you want to try that. $\endgroup$
    – JtheNinja
    Jun 24, 2016 at 22:41

1 Answer 1

0
$\begingroup$

Normal maps or other data maps' color space should be as Non-Color
also, I recommend turning off the Half-float Precision option for Normal maps. enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .