1
$\begingroup$

How to combine nodes-editor transparency with uv-mapped textures in Blender Render?
This question here is strongly related to the one that came up whilst I worked with that problem there. Same situation as before;
An object that shall act as a partly transparent mane.
The object below the mane shouldn't be affected by the mane's transparency. (In general no other object). transparency


As you can see, the result is not as wished. I honestly have no clue what to do since I'm pretty new to nodes editor.
If anyone knows how to fix this, I'd be happy for any help.
If needed, I will try to put up a file with those two objects. Just might take some time until I got all files sorted.

$\endgroup$
1
$\begingroup$

What I now found out thanks to this video (https://www.youtube.com/watch?v=BKxUKzpx--s), which showed me a slightly different way to get my transparency problem fixed, might be just a solution that was fine for me, because I will stick to game mode anyways.
So others who have the same problem and have no use for 'Blender game' might be dissapointed. It only helps in that direction. (Means, if anyone else has got a concrete solution for nodes editor in blender render, shall feel free to share their knowledge^^)
---
After I switched into Blender Game, I went to the materials-tab.
There showed up an option that I desperately needed. It's called "Game Settings" and I just needed to scroll through the options to select 'blend alpha'.
This made the texture show up with a blended alpha that worked fine.

When I switched to texture view, the texture still looked wrong; not transparent.
I checked the transparency-panel in materials-tab, selected raytrace and set alpha to 0.
Now the whole object appeared almost invisible.
After I then switched to texture-tab and selected full alpha control by the texture, the surface acted like expected.


Here the screenshots of the told settings:

Materials Tabmaterials tab
Texture Tab
texture tab

$\endgroup$
0
$\begingroup$

I'm not quite sure what I did, but with the Transparency > Alpha: at 0.6, like Img 1, I was able to produce Img 2.

Img 1:

enter image description here

Img 2:

enter image description here

I used Img 3's node setup and it started working. Suddenly, I could see the checker background behind the cube.

Img 3:

enter image description here

Here is the .blend file:

Edit:

Checker Background:

enter image description here

$\endgroup$
  • $\begingroup$ I took a look at the file so far, what I just found out was a different way to solve my problem. Nodes editor seemed to be unnecessary afterwards. I will reply to my question to show what I just found out. It somehow just will work for me, because I needed to switch mode anyways. I explain the rest in the answer, just gets more confusing otherwise. $\endgroup$ – xDonnervogelx Jul 3 '16 at 12:22
  • $\begingroup$ @xDonnervogelx If my answer helped, please consider accepting it. It would help me greatly and make me very happy. Plus, please consider that even if you accept your own answer, you won't get the +15 rep from it. $\endgroup$ – Shady Puck Jul 3 '16 at 12:23
  • 1
    $\begingroup$ I still am a bit confused about what exactly you tried out there. What do you mean by "produce"? I see that you mixed the values there. The thing is, that the texture itself hasn't got blended transparency. Mine does have so. It's hard to understand what way you went and what solution you earned, apart from having the whole texture by 60% alpha. The thing with the checker-background is new to me. Did you render it or enter a specific texture/materials-view? I'd need more information in total that's the problem. $\endgroup$ – xDonnervogelx Jul 3 '16 at 13:03
  • $\begingroup$ @xDonnervogelx It's in the world settings. See my edit. $\endgroup$ – Shady Puck Jul 3 '16 at 13:05
  • $\begingroup$ Ah okay, I see. But I fear that your reply has not so much to do with my question, maybe you misunderstood my problem in general? But cool thing that the world BG can be influenced by this, too, this is at least something I didn't know before. $\endgroup$ – xDonnervogelx Jul 3 '16 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.